Pydantic AI Web chat UI (Agent.to_web(), clai web): a website visited by the developer can trigger agent runs and server-side tool execution on the local chat endpoint
CVE-2026-107295GHSA-h4xc-3qfq-jf93
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pydantic-ai 2.28.0, 1.107.4; pydantic-ai-slim 2.28.0, 1.107.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pydantic-ai
- Affected
- >= 1.34.0, < 1.107.4>= 2.0.0b1, < 2.28.0
- Fixed in
- 1.107.4, 2.28.0
PyPI pydantic-ai-slim
- Affected
- >= 1.34.0, < 1.107.4>= 2.0.0b1, < 2.28.0
- Fixed in
- 1.107.4, 2.28.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h4xc-3qfq-jf93 lists affected ranges: PyPI pydantic-ai >=1.34.0 =2.0.0b1 =1.34.0 =2.0.0b1 <2.28.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h4xc-3qfq-jf93 lists affected ranges: PyPI pydantic-ai >=1.34.0 =2.0.0b1 =1.34.0 =2.0.0b1 <2.28.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:L
- EPSS
- CVE-2026-107295: 0.16% estimated exploitation activity in the next 30 days; percentile 4.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The Pydantic AI development web chat UI (Agent.toweb(), clai web) did not check the content type of requests to its chat endpoint. This allowed a website visited by a developer to submit a request to a chat UI running on that developer's machine, causing the served agent to run and to execute its tools with the privileges and credentials of the local process. Binding the web UI to localhost — the default — does not prevent this, because a page open in the developer's browser can reach the loopback address. Impact Applications and developers serving an agent through Agent.toweb() or clai web. The consequences depend on the tools the served agent exposes, and can include data disclosure as well as unwanted tool side effects. Tools marked requiresapproval=True were not protected either, because the endpoint trusts approval decisions relayed by the client. Mitigation Upgrade to a patched version. The chat endpoint now requires Content-Type: application/json and rejects other…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-h4xc-3qfq-jf93
- Revision 2 · amended ·
Amended from osv record GHSA-h4xc-3qfq-jf93
- Revision 1 · created ·
Published from ghsa record GHSA-h4xc-3qfq-jf93
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-107295 Advisory: Pydantic AI Web chat UI (`Agent.to_web()`, `clai web`): a website visited by the developer can trigger agent runs and server-side tool execution on the local chat endpoint IDs: CVE-2026-107295, GHSA-h4xc-3qfq-jf93 Record: https://patchnext.com/advisories/cve-2026-107295 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pydantic-ai 2.28.0, 1.107.4; pydantic-ai-slim 2.28.0, 1.107.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pydantic-ai: affected >= 1.34.0, < 1.107.4; >= 2.0.0b1, < 2.28.0; fixed in 1.107.4, 2.28.0 - PyPI pydantic-ai-slim: affected >= 1.34.0, < 1.107.4; >= 2.0.0b1, < 2.28.0; fixed in 1.107.4, 2.28.0 ## Suggested inspection (read-only) - `python -m pip show pydantic-ai`: prints the installed version. Run with the environment that serves production active. - `python -m pip show pydantic-ai-slim`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pydantic-ai, pydantic-ai-slim. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h4xc-3qfq-jf93 (GitHub-reviewed advisory GHSA-h4xc-3qfq-jf93 lists affected ranges: PyPI pydantic-ai >=1.34.0 =2.0.0b1 =1.34.0 =2.0.0b1 <2.28.0) - Verified: https://osv.dev/vulnerability/GHSA-h4xc-3qfq-jf93 (OSV record GHSA-h4xc-3qfq-jf93 lists affected ranges: PyPI pydantic-ai >=1.34.0 =2.0.0b1 =1.34.0 =2.0.0b1 <2.28.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…