Pydantic AI Web chat UI (Agent.to_web(), clai web): the local chat endpoint does not validate the Host header
CVE-2026-107292GHSA-q2xc-rrxj-58x9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pydantic-ai 2.30.0, 1.107.5; pydantic-ai-slim 2.30.0, 1.107.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pydantic-ai
- Affected
- >= 1.34.0, < 1.107.5>= 2.0.0b1, < 2.30.0
- Fixed in
- 1.107.5, 2.30.0
PyPI pydantic-ai-slim
- Affected
- >= 1.34.0, < 1.107.5>= 2.0.0b1, < 2.30.0
- Fixed in
- 1.107.5, 2.30.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q2xc-rrxj-58x9 lists affected ranges: PyPI pydantic-ai >=1.34.0 =2.0.0b1 =1.34.0 =2.0.0b1 <2.30.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q2xc-rrxj-58x9 lists affected ranges: PyPI pydantic-ai >=1.34.0 =2.0.0b1 =1.34.0 =2.0.0b1 <2.30.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:H/A:L
- EPSS
- CVE-2026-107292: 0.13% estimated exploitation activity in the next 30 days; percentile 2.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The Pydantic AI development web chat UI (Agent.toweb(), clai web) does not validate the Host header of incoming requests. A website a developer visits can use DNS rebinding to make requests to a chat UI running on that developer's machine appear same-origin to the browser, causing the served agent to run and to execute its tools with the privileges and credentials of the local process. Details Once a name the attacker controls resolves to the loopback address, the browser treats the request as same-origin, so neither an Origin check nor a CSRF token constrains it — a same-origin page can read the served UI and any token in it. Binding the web UI to localhost — the default — does not prevent this. Impact Applications and developers serving an agent through Agent.toweb() or clai web. The consequences depend on the tools the served agent exposes, and can include data disclosure as well as unwanted tool side effects. Current browser protections reduce but do not remove this…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-q2xc-rrxj-58x9
- Revision 2 · amended ·
Amended from osv record GHSA-q2xc-rrxj-58x9
- Revision 1 · created ·
Published from ghsa record GHSA-q2xc-rrxj-58x9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-107292 Advisory: Pydantic AI Web chat UI (`Agent.to_web()`, `clai web`): the local chat endpoint does not validate the `Host` header IDs: CVE-2026-107292, GHSA-q2xc-rrxj-58x9 Record: https://patchnext.com/advisories/cve-2026-107292 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pydantic-ai 2.30.0, 1.107.5; pydantic-ai-slim 2.30.0, 1.107.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pydantic-ai: affected >= 1.34.0, < 1.107.5; >= 2.0.0b1, < 2.30.0; fixed in 1.107.5, 2.30.0 - PyPI pydantic-ai-slim: affected >= 1.34.0, < 1.107.5; >= 2.0.0b1, < 2.30.0; fixed in 1.107.5, 2.30.0 ## Suggested inspection (read-only) - `python -m pip show pydantic-ai`: prints the installed version. Run with the environment that serves production active. - `python -m pip show pydantic-ai-slim`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pydantic-ai, pydantic-ai-slim. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q2xc-rrxj-58x9 (GitHub-reviewed advisory GHSA-q2xc-rrxj-58x9 lists affected ranges: PyPI pydantic-ai >=1.34.0 =2.0.0b1 =1.34.0 =2.0.0b1 <2.30.0) - Verified: https://osv.dev/vulnerability/GHSA-q2xc-rrxj-58x9 (OSV record GHSA-q2xc-rrxj-58x9 lists affected ranges: PyPI pydantic-ai >=1.34.0 =2.0.0b1 =1.34.0 =2.0.0b1 <2.30.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…