Pydantic AI: SSRF cloud-metadata blocklist bypass via IPv6 zone identifiers
CVE-2026-107289GHSA-vmxc-h2x2-jmf3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pydantic-ai 2.44.0, 1.107.6; pydantic-ai-slim 2.44.0, 1.107.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pydantic-ai
- Affected
- >= 1.56.0, < 1.107.6>= 2.0.0b1, < 2.44.0
- Fixed in
- 1.107.6, 2.44.0
PyPI pydantic-ai-slim
- Affected
- >= 1.56.0, < 1.107.6>= 2.0.0b1, < 2.44.0
- Fixed in
- 1.107.6, 2.44.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vmxc-h2x2-jmf3 lists affected ranges: PyPI pydantic-ai >=1.56.0 =2.0.0b1 =1.56.0 =2.0.0b1 <2.44.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vmxc-h2x2-jmf3 lists affected ranges: PyPI pydantic-ai >=1.56.0 =2.0.0b1 =1.56.0 =2.0.0b1 <2.44.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-107289: 0.39% estimated exploitation activity in the next 30 days; percentile 33.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When an application using Pydantic AI opts a URL into local network access — either a FileUrl with forcedownload='allow-local', or webfetchtool(allowlocalurls=True) — the cloud-metadata blocklist could be bypassed by appending an IPv6 zone identifier to a metadata address (for example fd00:ec2::254%251). The host ignores the zone identifier on a destination that is not link-local and delivers the request to the metadata endpoint anyway, exposing cloud IAM short-term credentials. This is an incomplete fix of GHSA-cqp8-fcvh-x7r3 / CVE-2026-46678 and GHSA-cg7w-rg45-pc59 / CVE-2026-48782, themselves follow-ups to CVE-2026-25580. The parent advisory's remediation guaranteed that cloud metadata endpoints are always blocked, even with local access allowed. That guarantee did not hold for zone-scoped spellings of the IPv6 metadata endpoints. Details The cloud-metadata guard compared IPv6 addresses against its blocklist by set membership. Python includes the zone identifier in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vmxc-h2x2-jmf3
- Revision 2 · amended ·
Amended from osv record GHSA-vmxc-h2x2-jmf3
- Revision 1 · created ·
Published from ghsa record GHSA-vmxc-h2x2-jmf3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-107289 Advisory: Pydantic AI: SSRF cloud-metadata blocklist bypass via IPv6 zone identifiers IDs: CVE-2026-107289, GHSA-vmxc-h2x2-jmf3 Record: https://patchnext.com/advisories/cve-2026-107289 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pydantic-ai 2.44.0, 1.107.6; pydantic-ai-slim 2.44.0, 1.107.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pydantic-ai: affected >= 1.56.0, < 1.107.6; >= 2.0.0b1, < 2.44.0; fixed in 1.107.6, 2.44.0 - PyPI pydantic-ai-slim: affected >= 1.56.0, < 1.107.6; >= 2.0.0b1, < 2.44.0; fixed in 1.107.6, 2.44.0 ## Suggested inspection (read-only) - `python -m pip show pydantic-ai`: prints the installed version. Run with the environment that serves production active. - `python -m pip show pydantic-ai-slim`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pydantic-ai, pydantic-ai-slim. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vmxc-h2x2-jmf3 (GitHub-reviewed advisory GHSA-vmxc-h2x2-jmf3 lists affected ranges: PyPI pydantic-ai >=1.56.0 =2.0.0b1 =1.56.0 =2.0.0b1 <2.44.0) - Verified: https://osv.dev/vulnerability/GHSA-vmxc-h2x2-jmf3 (OSV record GHSA-vmxc-h2x2-jmf3 lists affected ranges: PyPI pydantic-ai >=1.56.0 =2.0.0b1 =1.56.0 =2.0.0b1 <2.44.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…