Skip to content

← Actionable
Medium, CVSS 6.5amended

Pydantic AI: Excessive resource use when local web fetching converts nested HTML

CVE-2026-107287GHSA-v36g-jcw9-x7cw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pydantic-ai 2.52.0, 1.107.7; pydantic-ai-slim 2.52.0, 1.107.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pydantic-ai

    Affected
    >= 1.77.0, < 1.107.7>= 2.0.0b1, < 2.52.0
    Fixed in
    1.107.7, 2.52.0
  • PyPI pydantic-ai-slim

    Affected
    >= 1.77.0, < 1.107.7>= 2.0.0b1, < 2.52.0
    Fixed in
    1.107.7, 2.52.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-107287: 0.28% estimated exploitation activity in the next 30 days; percentile 20.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Applications using Pydantic AI's local web-fetch tool can experience excessive CPU and memory use when it converts attacker-controlled HTML. An agent must fetch the affected page; provider-native web fetching is not affected. Details Nested block elements cause HTML-to-Markdown conversion to reprocess accumulated text at each level and can greatly expand the intermediate output. The response-body limit bounds downloaded bytes, while the returned-content limit is applied only after conversion. On current releases, conversion runs in a worker thread but can still consume substantial resources and delay other work in the process. Older releases performed conversion on the event loop. Mitigation Upgrade to a patched release of pydantic-ai or pydantic-ai-slim. If you cannot upgrade yet, avoid using local web fetching for attacker-controlled HTML.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v36g-jcw9-x7cw

  2. Revision 2 · amended ·

    Amended from osv record GHSA-v36g-jcw9-x7cw

  3. Revision 1 · created ·

    Published from ghsa record GHSA-v36g-jcw9-x7cw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107287

Advisory: Pydantic AI: Excessive resource use when local web fetching converts nested HTML
IDs: CVE-2026-107287, GHSA-v36g-jcw9-x7cw
Record: https://patchnext.com/advisories/cve-2026-107287 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pydantic-ai 2.52.0, 1.107.7; pydantic-ai-slim 2.52.0, 1.107.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pydantic-ai: affected >= 1.77.0, < 1.107.7; >= 2.0.0b1, < 2.52.0; fixed in 1.107.7, 2.52.0
- PyPI pydantic-ai-slim: affected >= 1.77.0, < 1.107.7; >= 2.0.0b1, < 2.52.0; fixed in 1.107.7, 2.52.0

## Suggested inspection (read-only)
- `python -m pip show pydantic-ai`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show pydantic-ai-slim`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pydantic-ai, pydantic-ai-slim.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v36g-jcw9-x7cw (GitHub-reviewed advisory GHSA-v36g-jcw9-x7cw lists affected ranges: PyPI pydantic-ai >=1.77.0 =2.0.0b1 =1.77.0 =2.0.0b1 <2.52.0)
- Verified: https://osv.dev/vulnerability/GHSA-v36g-jcw9-x7cw (OSV record GHSA-v36g-jcw9-x7cw lists affected ranges: PyPI pydantic-ai >=1.77.0 =2.0.0b1 =1.77.0 =2.0.0b1 <2.52.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…