Skip to content

← Actionable
Medium, CVSS 5.3amended

Excelize: RIGHT() on supplementary-plane text slices with a negative index and panics

CVE-2026-107218GHSA-8jjq-8j9w-m2v6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/xuri/excelize/v2 2.11.1-0.20260908032718-ecd99d761fe0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-107218: 0.31% estimated exploitation activity in the next 30 days; percentile 23.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

leftRight (calc.go:14236) tests the length with countUTF16String, which counts a rune above U+FFFF as 2. The RIGHT branch on 14241 then slices []rune(text) at utf8.RuneCountInString(text)-numChars, which counts it as 1. For text with N such runes the two measures are 2N and N, so any numChars between them passes the guard and gives a negative index. The numChars < 0 check at 14216 does not help, since the value that gets through is positive. What makes it worth reporting is AutoFitColWidth, which evaluates formulas without looking like it does, so normalising an uploaded sheet is enough to reach it. One scoping correction to my own wording there: AutoFitColWidth was added in v2.11.0 and does not exist at v2.10.1, so on v2.10.1 the only reachable path is an explicit CalcCellValue. A 6,077-byte file containing two U+1D7D9 characters in A1 and RIGHT(A1,3) in B1 was created and then opened in a separate program without recovery enabled: So it is a regression, not an old defect. Commit…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8jjq-8j9w-m2v6

  2. Revision 1 · created ·

    Published from osv record GHSA-8jjq-8j9w-m2v6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107218

Advisory: Excelize: RIGHT() on supplementary-plane text slices with a negative index and panics
IDs: CVE-2026-107218, GHSA-8jjq-8j9w-m2v6
Record: https://patchnext.com/advisories/cve-2026-107218 (revision 2, source checked 26 Oct 2026, 15:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/xuri/excelize/v2 2.11.1-0.20260908032718-ecd99d761fe0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/xuri/excelize/v2: affected >= 2.10.1, < 2.11.1-0.20260908032718-ecd99d761fe0; fixed in 2.11.1-0.20260908032718-ecd99d761fe0

## Suggested inspection (read-only)
- Go github.com/xuri/excelize/v2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/xuri/excelize/v2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8jjq-8j9w-m2v6 (OSV record GHSA-8jjq-8j9w-m2v6 lists affected ranges: Go github.com/xuri/excelize/v2 >=2.10.1 <2.11.1-0.20260908032718-ecd99d761fe0 (fixed))
- Verified: https://github.com/advisories/GHSA-8jjq-8j9w-m2v6 (GitHub-reviewed advisory GHSA-8jjq-8j9w-m2v6 lists affected ranges: Go github.com/xuri/excelize/v2 >=2.10.1 <2.11.1-0.20260908032718-ecd99d761fe0)

Commands are suggestions: review each one before running it.

Loading voting…