Skip to content

← Actionable
Medium, CVSS 5.1

Canonical MicroCeph: path traversal issue in the remote-import AP

CVE-2026-10720GHSA-xg3j-c7q4-f9ph

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/canonical/microceph/microceph 0.0.0-20260609072127-5c2760d8fb76), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:L/VA:L/SC:N/SI:H/SA:H · score source
EPSS
  • CVE-2026-10720: 0.30% estimated exploitation activity in the next 30 days; percentile 22.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Canonical MicroCeph versions from the squid and tentacle track are vulnerable to a path traversal issue in the remote-import API. Holders of a trusted cluster mTLS certificate (such as enrolled cluster members) or join token can manipulate files in an imported remote cluster within the /var/snap/microceph confinement. This would allow daemon disruption and pollution of the cluster state.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xg3j-c7q4-f9ph

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-10720

Advisory: Canonical MicroCeph: path traversal issue in the remote-import AP
IDs: CVE-2026-10720, GHSA-xg3j-c7q4-f9ph
Record: https://patchnext.com/advisories/cve-2026-10720 (revision 1, source checked 26 Oct 2026, 15:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/canonical/microceph/microceph 0.0.0-20260609072127-5c2760d8fb76. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/canonical/microceph/microceph: affected < 0.0.0-20260609072127-5c2760d8fb76; fixed in 0.0.0-20260609072127-5c2760d8fb76

## Suggested inspection (read-only)
- Go github.com/canonical/microceph/microceph: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/canonical/microceph/microceph.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xg3j-c7q4-f9ph (GitHub-reviewed advisory GHSA-xg3j-c7q4-f9ph lists affected ranges: Go github.com/canonical/microceph/microceph >=0 <0.0.0-20260609072127-5c2760d8fb76)

Commands are suggestions: review each one before running it.

Loading voting…