Backstage: Improper entity validation in deprecated Kubernetes services endpoint
CVE-2026-106563GHSA-r9ph-3637-55px
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-kubernetes-backend 0.21.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @backstage/plugin-kubernetes-backend
- Affected
- < 0.21.8
- Fixed in
- 0.21.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r9ph-3637-55px lists affected ranges: npm @backstage/plugin-kubernetes-backend >=0 <0.21.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r9ph-3637-55px lists affected ranges: npm @backstage/plugin-kubernetes-backend >=0 <0.21.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-106563: 0.22% estimated exploitation activity in the next 30 days; percentile 13.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An authenticated user with Kubernetes read permissions could access Kubernetes workload data beyond their intended scope by supplying crafted entity data to the deprecated services endpoint. The exposure is limited to read-only access to Kubernetes object metadata across configured clusters. Patches Patched in @backstage/plugin-kubernetes-backend version 0.21.8. Workarounds - Disable the deprecated /services/:serviceId route by deploying a custom Kubernetes router that omits it. - Restrict access to the kubernetes.resources.read permission to limit the set of users who can reach the endpoint.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-r9ph-3637-55px
- Revision 2 · amended ·
Amended from osv record GHSA-r9ph-3637-55px
- Revision 1 · created ·
Published from ghsa record GHSA-r9ph-3637-55px
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-106563 Advisory: Backstage: Improper entity validation in deprecated Kubernetes services endpoint IDs: CVE-2026-106563, GHSA-r9ph-3637-55px Record: https://patchnext.com/advisories/cve-2026-106563 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-kubernetes-backend 0.21.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @backstage/plugin-kubernetes-backend: affected < 0.21.8; fixed in 0.21.8 ## Suggested inspection (read-only) - `npm ls @backstage/plugin-kubernetes-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @backstage/plugin-kubernetes-backend. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r9ph-3637-55px (GitHub-reviewed advisory GHSA-r9ph-3637-55px lists affected ranges: npm @backstage/plugin-kubernetes-backend >=0 <0.21.8) - Verified: https://osv.dev/vulnerability/GHSA-r9ph-3637-55px (OSV record GHSA-r9ph-3637-55px lists affected ranges: npm @backstage/plugin-kubernetes-backend >=0 <0.21.8 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…