Backstage: Improper input validation in Confluence to Markdown scaffolder module
CVE-2026-106559GHSA-75qf-886x-5xf2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-scaffolder-backend-module-confluence-to-markdown 0.3.25), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @backstage/plugin-scaffolder-backend-module-confluence-to-markdown
- Affected
- < 0.3.25
- Fixed in
- 0.3.25
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-75qf-886x-5xf2 lists affected ranges: npm @backstage/plugin-scaffolder-backend-module-confluence-to-markdown >=0 <0.3.25
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-75qf-886x-5xf2 lists affected ranges: npm @backstage/plugin-scaffolder-backend-module-confluence-to-markdown >=0 <0.3.25 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:L
- EPSS
- CVE-2026-106559: 0.33% estimated exploitation activity in the next 30 days; percentile 26.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Insufficient input validation in the Confluence to Markdown scaffolder module could allow an attacker to influence file write operations during template execution. Exploitation requires a Backstage user to run a template that processes attacker-influenced Confluence content. Patches Patched in @backstage/plugin-scaffolder-backend-module-confluence-to-markdown version 0.3.25 Workarounds If unable to update immediately: - Restrict Confluence edit access to trusted users. - Review Confluence page content before running scaffolder templates against untrusted pages.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-75qf-886x-5xf2
- Revision 2 · amended ·
Amended from osv record GHSA-75qf-886x-5xf2
- Revision 1 · created ·
Published from ghsa record GHSA-75qf-886x-5xf2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-106559 Advisory: Backstage: Improper input validation in Confluence to Markdown scaffolder module IDs: CVE-2026-106559, GHSA-75qf-886x-5xf2 Record: https://patchnext.com/advisories/cve-2026-106559 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-scaffolder-backend-module-confluence-to-markdown 0.3.25. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @backstage/plugin-scaffolder-backend-module-confluence-to-markdown: affected < 0.3.25; fixed in 0.3.25 ## Suggested inspection (read-only) - `npm ls @backstage/plugin-scaffolder-backend-module-confluence-to-markdown --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @backstage/plugin-scaffolder-backend-module-confluence-to-markdown. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-75qf-886x-5xf2 (GitHub-reviewed advisory GHSA-75qf-886x-5xf2 lists affected ranges: npm @backstage/plugin-scaffolder-backend-module-confluence-to-markdown >=0 <0.3.25) - Verified: https://osv.dev/vulnerability/GHSA-75qf-886x-5xf2 (OSV record GHSA-75qf-886x-5xf2 lists affected ranges: npm @backstage/plugin-scaffolder-backend-module-confluence-to-markdown >=0 <0.3.25 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…