Backstage has improper input validation in TechDocs Markdown extension configuration
CVE-2026-106557GHSA-f7v3-xhm6-w245
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-techdocs-node 1.15.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @backstage/plugin-techdocs-node
- Affected
- < 1.15.4
- Fixed in
- 1.15.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f7v3-xhm6-w245 lists affected ranges: npm @backstage/plugin-techdocs-node >=0 <1.15.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f7v3-xhm6-w245 lists affected ranges: npm @backstage/plugin-techdocs-node >=0 <1.15.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-106557: 0.38% estimated exploitation activity in the next 30 days; percentile 31.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An authenticated user who can register or modify documentation sources may cause a TechDocs build to access resources outside the intended documentation boundary. Depending on deployment configuration, this may expose sensitive backend-host data or internal network resources. Patches Patched in @backstage/plugin-techdocs-node version 1.15.4. Adopters must also use pymdown-extensions version 10.21.3 or newer, normally through mkdocs-techdocs-core version 1.7.0 or newer. @backstage/plugin-techdocs-node does not control the Python dependencies used by the generator; with an older PyMdown release, snippets may remain vulnerable to file inclusion even after their configuration is sanitized. Workarounds - Generate TechDocs only from trusted repositories with reviewed MkDocs configuration. - Use isolated build environments with restricted filesystem access and network egress. - Prefer externally generated TechDocs with appropriately sandboxed CI.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-f7v3-xhm6-w245
- Revision 2 · amended ·
Amended from osv record GHSA-f7v3-xhm6-w245
- Revision 1 · created ·
Published from ghsa record GHSA-f7v3-xhm6-w245
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-106557 Advisory: Backstage has improper input validation in TechDocs Markdown extension configuration IDs: CVE-2026-106557, GHSA-f7v3-xhm6-w245 Record: https://patchnext.com/advisories/cve-2026-106557 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-techdocs-node 1.15.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @backstage/plugin-techdocs-node: affected < 1.15.4; fixed in 1.15.4 ## Suggested inspection (read-only) - `npm ls @backstage/plugin-techdocs-node --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @backstage/plugin-techdocs-node. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f7v3-xhm6-w245 (GitHub-reviewed advisory GHSA-f7v3-xhm6-w245 lists affected ranges: npm @backstage/plugin-techdocs-node >=0 <1.15.4) - Verified: https://osv.dev/vulnerability/GHSA-f7v3-xhm6-w245 (OSV record GHSA-f7v3-xhm6-w245 lists affected ranges: npm @backstage/plugin-techdocs-node >=0 <1.15.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…