Skip to content

← Actionable
High, CVSS 7.7amended

Backstage: Improper validation of MkDocs theme configuration in TechDocs

CVE-2026-106509GHSA-8w7q-29mw-gf5c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-techdocs-node 1.15.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:L
EPSS
  • CVE-2026-106509: 0.52% estimated exploitation activity in the next 30 days; percentile 44.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When TechDocs is configured to build documentation locally or in a container, a user with write access to a registered repository can include configuration values in mkdocs.yml that cause arbitrary code execution during the documentation build process. Patches Patched in @backstage/plugin-techdocs-node version 1.15.4 Workarounds - Configure TechDocs with techdocs.generator.runIn: 'docker' instead of 'local' to provide container isolation, though this does not fully mitigate the risk. - Restrict write access to repositories registered in the Backstage catalog to trusted users.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8w7q-29mw-gf5c

  2. Revision 2 · amended ·

    Amended from osv record GHSA-8w7q-29mw-gf5c

  3. Revision 1 · created ·

    Published from ghsa record GHSA-8w7q-29mw-gf5c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106509

Advisory: Backstage: Improper validation of MkDocs theme configuration in TechDocs
IDs: CVE-2026-106509, GHSA-8w7q-29mw-gf5c
Record: https://patchnext.com/advisories/cve-2026-106509 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-techdocs-node 1.15.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/plugin-techdocs-node: affected < 1.15.4; fixed in 1.15.4

## Suggested inspection (read-only)
- `npm ls @backstage/plugin-techdocs-node --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/plugin-techdocs-node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8w7q-29mw-gf5c (GitHub-reviewed advisory GHSA-8w7q-29mw-gf5c lists affected ranges: npm @backstage/plugin-techdocs-node >=0 <1.15.4)
- Verified: https://osv.dev/vulnerability/GHSA-8w7q-29mw-gf5c (OSV record GHSA-8w7q-29mw-gf5c lists affected ranges: npm @backstage/plugin-techdocs-node >=0 <1.15.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…