Skip to content

← Actionable
Medium, CVSS 5.3amended

Backstage has potential file exposure through local TechDocs publisher

CVE-2026-106508GHSA-cm77-ch27-6w6v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-techdocs-node 1.15.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-106508: 0.39% estimated exploitation activity in the next 30 days; percentile 33.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When using the local TechDocs publisher (techdocs.publisher.type: 'local'), it was possible for the documentation serving endpoint to follow filesystem references outside the intended documentation tree, potentially exposing host files to authenticated users. This is mitigated by the fact that exploration requires preconditions that do not arise through normal MkDocs operation. Cloud-based publishers (S3, GCS, Azure Blob Storage) are not affected. Patches Patched in @backstage/plugin-techdocs-node version 1.15.4 Workarounds If you cannot upgrade immediately, consider switching to an external store for published TechDocs content (e.g. awsS3, googleGcs, or azureBlobStorage publishers)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cm77-ch27-6w6v

  2. Revision 2 · amended ·

    Amended from osv record GHSA-cm77-ch27-6w6v

  3. Revision 1 · created ·

    Published from ghsa record GHSA-cm77-ch27-6w6v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106508

Advisory: Backstage has potential file exposure through local TechDocs publisher
IDs: CVE-2026-106508, GHSA-cm77-ch27-6w6v
Record: https://patchnext.com/advisories/cve-2026-106508 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-techdocs-node 1.15.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/plugin-techdocs-node: affected < 1.15.4; fixed in 1.15.4

## Suggested inspection (read-only)
- `npm ls @backstage/plugin-techdocs-node --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/plugin-techdocs-node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cm77-ch27-6w6v (GitHub-reviewed advisory GHSA-cm77-ch27-6w6v lists affected ranges: npm @backstage/plugin-techdocs-node >=0 <1.15.4)
- Verified: https://osv.dev/vulnerability/GHSA-cm77-ch27-6w6v (OSV record GHSA-cm77-ch27-6w6v lists affected ranges: npm @backstage/plugin-techdocs-node >=0 <1.15.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…