Backstage has improper input validation in scaffolder task list ordering
CVE-2026-106506GHSA-vwp5-f99x-x3rq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-scaffolder-backend 4.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @backstage/plugin-scaffolder-backend
- Affected
- < 4.1.0
- Fixed in
- 4.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vwp5-f99x-x3rq lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 <4.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vwp5-f99x-x3rq lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 <4.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-106506: 0.22% estimated exploitation activity in the next 30 days; percentile 12.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An authenticated Backstage user with permission to create and read relevant scaffolder tasks may be able to infer confidential task data under specific conditions. Successful exploitation requires retained task secrets, visibility of a target task, knowledge of the secret structure, and repeated requests. Patches Patched in @backstage/plugin-scaffolder-backend version 4.1.0 Workarounds - At the gateway or reverse proxy, reject task-list requests that specify custom ordering, or allow ordering only by createdat, status, and createdby. - Restrict scaffolder task creation and task read permissions to trusted users, preferably using owner-based task-read conditions. - Disabling task recovery can reduce secret retention after a task is claimed, but it does not protect secrets in queued tasks and should not be treated as complete mitigation.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vwp5-f99x-x3rq
- Revision 2 · amended ·
Amended from osv record GHSA-vwp5-f99x-x3rq
- Revision 1 · created ·
Published from ghsa record GHSA-vwp5-f99x-x3rq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-106506 Advisory: Backstage has improper input validation in scaffolder task list ordering IDs: CVE-2026-106506, GHSA-vwp5-f99x-x3rq Record: https://patchnext.com/advisories/cve-2026-106506 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-scaffolder-backend 4.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @backstage/plugin-scaffolder-backend: affected < 4.1.0; fixed in 4.1.0 ## Suggested inspection (read-only) - `npm ls @backstage/plugin-scaffolder-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @backstage/plugin-scaffolder-backend. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vwp5-f99x-x3rq (GitHub-reviewed advisory GHSA-vwp5-f99x-x3rq lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 <4.1.0) - Verified: https://osv.dev/vulnerability/GHSA-vwp5-f99x-x3rq (OSV record GHSA-vwp5-f99x-x3rq lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 <4.1.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…