Skip to content

← Actionable
Medium, CVSS 6.5amended

Backstage has sensitive information exposure in scaffolder task logs

CVE-2026-106504GHSA-4xvq-3m68-h444

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-scaffolder-backend 4.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-106504: 0.26% estimated exploitation activity in the next 30 days; percentile 17.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated user who can create and read scaffolder tasks may be able to observe sensitive values in task logs in deployments with restrictive action permissions and affected templates. Exploitation requires a denied action whose input contains such a value. Patches Patched in @backstage/plugin-scaffolder-backend version 4.1.0 Workarounds - Restrict scaffolder task creation and task-log reading to trusted users. - Avoid placing centrally managed sensitive values in inputs to actions that may be denied until upgrading. References - Backstage threat model - Backstage permissions overview

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4xvq-3m68-h444

  2. Revision 2 · amended ·

    Amended from osv record GHSA-4xvq-3m68-h444

  3. Revision 1 · created ·

    Published from ghsa record GHSA-4xvq-3m68-h444

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106504

Advisory: Backstage has sensitive information exposure in scaffolder task logs
IDs: CVE-2026-106504, GHSA-4xvq-3m68-h444
Record: https://patchnext.com/advisories/cve-2026-106504 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-scaffolder-backend 4.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/plugin-scaffolder-backend: affected < 4.1.0; fixed in 4.1.0

## Suggested inspection (read-only)
- `npm ls @backstage/plugin-scaffolder-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/plugin-scaffolder-backend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4xvq-3m68-h444 (GitHub-reviewed advisory GHSA-4xvq-3m68-h444 lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 <4.1.0)
- Verified: https://osv.dev/vulnerability/GHSA-4xvq-3m68-h444 (OSV record GHSA-4xvq-3m68-h444 lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 <4.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…