Skip to content

← Actionable
High, CVSS 8.1amended

Backstage: Scaffolder action input authorization bypass

CVE-2026-106503GHSA-hmp2-4m7g-22cv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-scaffolder-backend 4.1.0, 4.0.3, 3.4.1, 3.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-106503: 0.49% estimated exploitation activity in the next 30 days; percentile 42.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated user with access to affected Scaffolder templates could bypass configured action restrictions. Depending on integration credentials, this could grant unauthorized access to repositories and related source-control resources. Patches Patched in @backstage/plugin-scaffolder-backend version 4.1.0 Workarounds - Restrict affected Scaffolder actions to trusted users and configure source-control integrations with least-privilege credentials.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hmp2-4m7g-22cv

  2. Revision 2 · amended ·

    Amended from osv record GHSA-hmp2-4m7g-22cv

  3. Revision 1 · created ·

    Published from ghsa record GHSA-hmp2-4m7g-22cv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106503

Advisory: Backstage: Scaffolder action input authorization bypass
IDs: CVE-2026-106503, GHSA-hmp2-4m7g-22cv
Record: https://patchnext.com/advisories/cve-2026-106503 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-scaffolder-backend 4.1.0, 4.0.3, 3.4.1, 3.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/plugin-scaffolder-backend: affected < 3.3.1; >= 3.4.0, < 3.4.1; >= 4.0.0, < 4.0.3; >= 4.0.4, < 4.1.0; fixed in 3.3.1, 3.4.1, 4.0.3, 4.1.0

## Suggested inspection (read-only)
- `npm ls @backstage/plugin-scaffolder-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/plugin-scaffolder-backend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hmp2-4m7g-22cv (GitHub-reviewed advisory GHSA-hmp2-4m7g-22cv lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 =3.4.0 =4.0.0 =4.0.4 <4.1.0)
- Verified: https://osv.dev/vulnerability/GHSA-hmp2-4m7g-22cv (OSV record GHSA-hmp2-4m7g-22cv lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 =3.4.0 =4.0.0 =4.0.4 <4.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…