Skip to content

← Actionable
Critical, CVSS 9.6amended

Backstage: Sensitive information exposure in Scaffolder

CVE-2026-106501GHSA-g2v8-7jhw-pp8p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-scaffolder-backend 4.1.0, 4.0.3, 3.4.1, 3.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-106501: 0.48% estimated exploitation activity in the next 30 days; percentile 41.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated Backstage user who can read another user's Scaffolder task may receive internal execution data. In deployments where that data contains credentials for an external service, this may permit disclosure and unauthorized changes in that external service. Patches Patched in @backstage/plugin-scaffolder-backend version 4.1.0 Workarounds - Configure scaffolder.task.read with the isTaskOwner condition so users can only read tasks they created. - Restrict affected integrations and workflows to trusted operators until an upgrade is available.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g2v8-7jhw-pp8p

  2. Revision 2 · amended ·

    Amended from osv record GHSA-g2v8-7jhw-pp8p

  3. Revision 1 · created ·

    Published from ghsa record GHSA-g2v8-7jhw-pp8p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106501

Advisory: Backstage: Sensitive information exposure in Scaffolder
IDs: CVE-2026-106501, GHSA-g2v8-7jhw-pp8p
Record: https://patchnext.com/advisories/cve-2026-106501 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-scaffolder-backend 4.1.0, 4.0.3, 3.4.1, 3.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/plugin-scaffolder-backend: affected < 3.3.1; >= 3.4.0, < 3.4.1; >= 4.0.0, < 4.0.3; >= 4.0.4, < 4.1.0; fixed in 3.3.1, 3.4.1, 4.0.3, 4.1.0

## Suggested inspection (read-only)
- `npm ls @backstage/plugin-scaffolder-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/plugin-scaffolder-backend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g2v8-7jhw-pp8p (GitHub-reviewed advisory GHSA-g2v8-7jhw-pp8p lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 =3.4.0 =4.0.0 =4.0.4 <4.1.0)
- Verified: https://osv.dev/vulnerability/GHSA-g2v8-7jhw-pp8p (OSV record GHSA-g2v8-7jhw-pp8p lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 =3.4.0 =4.0.0 =4.0.4 <4.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…