Backstage: Improper task state validation in Scaffolder backend
CVE-2026-106500GHSA-xvgh-hmx8-9xxf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-scaffolder-backend 4.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @backstage/plugin-scaffolder-backend
- Affected
- < 4.1.0
- Fixed in
- 4.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xvgh-hmx8-9xxf lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 <4.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xvgh-hmx8-9xxf lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 <4.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-106500: 0.34% estimated exploitation activity in the next 30 days; percentile 27.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An authenticated user with permission to create and access Scaffolder tasks may, under specific timing and deployment conditions, affect files accessible to the Backstage backend. If backend application files are writable, the confidentiality, integrity, and availability of the backend may be compromised. Patches Patched in @backstage/plugin-scaffolder-backend version 4.1.0 Workarounds - Restrict Scaffolder task creation and task-read permissions to trusted users through the permission policy. - Limit who can register or modify templates and which Scaffolder actions may execute. - Run backend application files read-only outside a dedicated, least-privilege Scaffolder working directory. References - Authorizing Scaffolder tasks, parameters, steps, and actions
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xvgh-hmx8-9xxf
- Revision 2 · amended ·
Amended from osv record GHSA-xvgh-hmx8-9xxf
- Revision 1 · created ·
Published from ghsa record GHSA-xvgh-hmx8-9xxf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-106500 Advisory: Backstage: Improper task state validation in Scaffolder backend IDs: CVE-2026-106500, GHSA-xvgh-hmx8-9xxf Record: https://patchnext.com/advisories/cve-2026-106500 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-scaffolder-backend 4.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @backstage/plugin-scaffolder-backend: affected < 4.1.0; fixed in 4.1.0 ## Suggested inspection (read-only) - `npm ls @backstage/plugin-scaffolder-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @backstage/plugin-scaffolder-backend. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xvgh-hmx8-9xxf (GitHub-reviewed advisory GHSA-xvgh-hmx8-9xxf lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 <4.1.0) - Verified: https://osv.dev/vulnerability/GHSA-xvgh-hmx8-9xxf (OSV record GHSA-xvgh-hmx8-9xxf lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 <4.1.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…