Backstage: Improper URL validation in catalog entity placeholder resolution
CVE-2026-106498GHSA-qgvj-qcf8-xq73
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-catalog-backend 3.9.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @backstage/plugin-catalog-backend
- Affected
- < 3.9.1
- Fixed in
- 3.9.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qgvj-qcf8-xq73 lists affected ranges: npm @backstage/plugin-catalog-backend >=0 <3.9.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qgvj-qcf8-xq73 lists affected ranges: npm @backstage/plugin-catalog-backend >=0 <3.9.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-106498: 0.31% estimated exploitation activity in the next 30 days; percentile 23.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An authenticated Backstage user could craft a catalog entity with placeholder directives that reference resources outside the entity's source repository. Under certain configurations, this could allow access to data not intended to be available to the user. Patches Patched in @backstage/plugin-catalog-backend version 3.9.1 Workarounds If you're not able to update immediately: - Limit the scope of integration credentials (e.g., GitHub tokens) to only the repositories that Backstage needs to access.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-qgvj-qcf8-xq73
- Revision 2 · amended ·
Amended from osv record GHSA-qgvj-qcf8-xq73
- Revision 1 · created ·
Published from ghsa record GHSA-qgvj-qcf8-xq73
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-106498 Advisory: Backstage: Improper URL validation in catalog entity placeholder resolution IDs: CVE-2026-106498, GHSA-qgvj-qcf8-xq73 Record: https://patchnext.com/advisories/cve-2026-106498 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-catalog-backend 3.9.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @backstage/plugin-catalog-backend: affected < 3.9.1; fixed in 3.9.1 ## Suggested inspection (read-only) - `npm ls @backstage/plugin-catalog-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @backstage/plugin-catalog-backend. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qgvj-qcf8-xq73 (GitHub-reviewed advisory GHSA-qgvj-qcf8-xq73 lists affected ranges: npm @backstage/plugin-catalog-backend >=0 <3.9.1) - Verified: https://osv.dev/vulnerability/GHSA-qgvj-qcf8-xq73 (OSV record GHSA-qgvj-qcf8-xq73 lists affected ranges: npm @backstage/plugin-catalog-backend >=0 <3.9.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…