Backstage: Improper preservation of access restrictions during service credential delegation
CVE-2026-106492GHSA-cq7v-rfgc-5c7v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/backend-defaults 0.17.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @backstage/backend-defaults
- Affected
- < 0.17.8
- Fixed in
- 0.17.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cq7v-rfgc-5c7v lists affected ranges: npm @backstage/backend-defaults >=0 <0.17.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cq7v-rfgc-5c7v lists affected ranges: npm @backstage/backend-defaults >=0 <0.17.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L
- EPSS
- CVE-2026-106492: 0.21% estimated exploitation activity in the next 30 days; percentile 10.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An external service credential configured with access restrictions (e.g., read-only) could bypass those restrictions by routing requests through plugin delegation paths. This could allow a restricted service to perform operations beyond its intended scope, including write operations on plugins it was restricted to read-only access for. Patches Patched in @backstage/backend-defaults version 0.17.8 Workarounds If you're unable to upgrade immediately: - If practical, replace restricted credentials with separate, purpose-specific unrestricted credentials scoped to trusted consumers. - Restrict network-level access to Backstage backend API endpoints to trusted callers only.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-cq7v-rfgc-5c7v
- Revision 2 · amended ·
Amended from osv record GHSA-cq7v-rfgc-5c7v
- Revision 1 · created ·
Published from ghsa record GHSA-cq7v-rfgc-5c7v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-106492 Advisory: Backstage: Improper preservation of access restrictions during service credential delegation IDs: CVE-2026-106492, GHSA-cq7v-rfgc-5c7v Record: https://patchnext.com/advisories/cve-2026-106492 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @backstage/backend-defaults 0.17.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @backstage/backend-defaults: affected < 0.17.8; fixed in 0.17.8 ## Suggested inspection (read-only) - `npm ls @backstage/backend-defaults --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @backstage/backend-defaults. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cq7v-rfgc-5c7v (GitHub-reviewed advisory GHSA-cq7v-rfgc-5c7v lists affected ranges: npm @backstage/backend-defaults >=0 <0.17.8) - Verified: https://osv.dev/vulnerability/GHSA-cq7v-rfgc-5c7v (OSV record GHSA-cq7v-rfgc-5c7v lists affected ranges: npm @backstage/backend-defaults >=0 <0.17.8 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…