Skip to content

← Actionable
Medium, CVSS 6.5amended

Backstage: Improper input validation in TechDocs static content requests

CVE-2026-106490GHSA-7mfx-xg57-53c9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-techdocs-backend 2.2.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-106490: 0.37% estimated exploitation activity in the next 30 days; percentile 30.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When using the Azure Blob Storage provider, an authenticated Backstage user may be able to read restricted TechDocs content when entity-level permissions are enabled. Deployments that intentionally disable the default backend authentication policy may have broader exposure. Patches Patched in @backstage/plugin-techdocs-backend version 2.2.4 Workarounds - Restrict access to the TechDocs backend to users who are permitted to view all stored documentation until an upgrade can be applied. - Keep the default backend authentication policy enabled.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7mfx-xg57-53c9

  2. Revision 2 · amended ·

    Amended from osv record GHSA-7mfx-xg57-53c9

  3. Revision 1 · created ·

    Published from ghsa record GHSA-7mfx-xg57-53c9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106490

Advisory: Backstage: Improper input validation in TechDocs static content requests
IDs: CVE-2026-106490, GHSA-7mfx-xg57-53c9
Record: https://patchnext.com/advisories/cve-2026-106490 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-techdocs-backend 2.2.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/plugin-techdocs-backend: affected < 2.2.4; fixed in 2.2.4

## Suggested inspection (read-only)
- `npm ls @backstage/plugin-techdocs-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/plugin-techdocs-backend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7mfx-xg57-53c9 (GitHub-reviewed advisory GHSA-7mfx-xg57-53c9 lists affected ranges: npm @backstage/plugin-techdocs-backend >=0 <2.2.4)
- Verified: https://osv.dev/vulnerability/GHSA-7mfx-xg57-53c9 (OSV record GHSA-7mfx-xg57-53c9 lists affected ranges: npm @backstage/plugin-techdocs-backend >=0 <2.2.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…