Skip to content

← Actionable
High, CVSS 8.1amended

Backstage: Improper authentication in the OIDC provider

CVE-2026-106488GHSA-826h-28h9-65hg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-auth-backend-module-oidc-provider 0.4.20), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-106488: 0.28% estimated exploitation activity in the next 30 days; percentile 20.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Deployments using OIDC email-based identity resolution with a provider that permits unverified email addresses may allow an authenticated provider user to assume another catalog identity. This may grant access and permissions associated with that user. No direct availability impact is demonstrated. Patches Patched in @backstage/plugin-auth-backend-module-oidc-provider version 0.4.20. Workarounds - Disable email-based sign-in resolution for the OIDC provider, or require the identity provider to verify email addresses before allowing sign-in.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-826h-28h9-65hg

  2. Revision 2 · amended ·

    Amended from osv record GHSA-826h-28h9-65hg

  3. Revision 1 · created ·

    Published from ghsa record GHSA-826h-28h9-65hg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106488

Advisory: Backstage: Improper authentication in the OIDC provider
IDs: CVE-2026-106488, GHSA-826h-28h9-65hg
Record: https://patchnext.com/advisories/cve-2026-106488 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-auth-backend-module-oidc-provider 0.4.20. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/plugin-auth-backend-module-oidc-provider: affected < 0.4.20; fixed in 0.4.20

## Suggested inspection (read-only)
- `npm ls @backstage/plugin-auth-backend-module-oidc-provider --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/plugin-auth-backend-module-oidc-provider.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-826h-28h9-65hg (GitHub-reviewed advisory GHSA-826h-28h9-65hg lists affected ranges: npm @backstage/plugin-auth-backend-module-oidc-provider >=0 <0.4.20)
- Verified: https://osv.dev/vulnerability/GHSA-826h-28h9-65hg (OSV record GHSA-826h-28h9-65hg lists affected ranges: npm @backstage/plugin-auth-backend-module-oidc-provider >=0 <0.4.20 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…