Skip to content

← Actionable
Medium, CVSS 6.8amended

Backstage: Explicit negative email verification can be ignored during shared OAuth profile normalization

CVE-2026-106460GHSA-xm5q-p7w3-x6cp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-auth-node 0.7.5, 0.6.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-106460: 0.40% estimated exploitation activity in the next 30 days; percentile 33.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Several Passport-based authentication providers use shared OAuth profile normalization from @backstage/plugin-auth-node. Affected versions may pass an email to email-based sign-in resolvers even when verification metadata supplied for that same address is explicitly negative. The ID-token-only fallback likewise did not consistently respect emailverified: false. Exploitation requires a deployment where an admitted identity-provider user can supply or change an email address without verification and Backstage uses that profile email to resolve catalog identities. In that configuration, the user may be able to assume another catalog identity and obtain its associated access and permissions. An absent emailverified claim is not by itself considered an affected condition. Some providers rely on authoritative organizational provisioning and intentionally omit the optional claim. Operators using email-based sign-in resolution must ensure that the configured provider restricts sign-in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xm5q-p7w3-x6cp

  2. Revision 2 · amended ·

    Amended from osv record GHSA-xm5q-p7w3-x6cp

  3. Revision 1 · created ·

    Published from ghsa record GHSA-xm5q-p7w3-x6cp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106460

Advisory: Backstage: Explicit negative email verification can be ignored during shared OAuth profile normalization
IDs: CVE-2026-106460, GHSA-xm5q-p7w3-x6cp
Record: https://patchnext.com/advisories/cve-2026-106460 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-auth-node 0.7.5, 0.6.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/plugin-auth-node: affected >= 0.3.0, < 0.6.15; >= 0.7.0, < 0.7.5; fixed in 0.6.15, 0.7.5

## Suggested inspection (read-only)
- `npm ls @backstage/plugin-auth-node --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/plugin-auth-node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xm5q-p7w3-x6cp (GitHub-reviewed advisory GHSA-xm5q-p7w3-x6cp lists affected ranges: npm @backstage/plugin-auth-node >=0.3.0 =0.7.0 <0.7.5)
- Verified: https://osv.dev/vulnerability/GHSA-xm5q-p7w3-x6cp (OSV record GHSA-xm5q-p7w3-x6cp lists affected ranges: npm @backstage/plugin-auth-node >=0.3.0 =0.7.0 <0.7.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…