Skip to content

← Actionable
Medium, CVSS 5.3amended

yawkat LZ4 Java: LZ4BlockInputStream allocates an unvalidated compressed length from the stream header

CVE-2026-106452GHSA-4v53-57pg-c464

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven at.yawk.lz4:lz4-java

    Affected
    <= 1.11.1
    Fixed in
    1.11.2
  • Maven org.lz4:lz4-java

    Affected
    <= 1.8.1
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-106452: 0.45% estimated exploitation activity in the next 30 days; percentile 39.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary LZ4BlockInputStream grows its compressed-input buffer to the attacker-controlled compressedLen value from the legacy LZ4Block stream header before reading any payload bytes. A header-only input can therefore trigger a near-2 GiB allocation and exhaust the JVM heap. Details In net.jpountz.lz4.LZ4BlockInputStream, refill() validates that compressedLen is nonnegative but does not cap it before allocation: The paired LZ4BlockOutputStream never emits such a block. If compression is not smaller than the original block, it writes the block as RAW: Existing readers generally accept noncanonical LZ4-method blocks where compressedLen = originalLen, but no canonical writer found produces them. Impact Applications that pass attacker-controlled legacy LZ4Block streams to LZ4BlockInputStream can suffer heap exhaustion from a header-only input. The impact is availability-only and requires no valid compressed payload. Patch As of lz4-java 1.11.2, lz4-java rejects lz4 blocks where the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4v53-57pg-c464

  2. Revision 1 · created ·

    Published from osv record GHSA-4v53-57pg-c464

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106452

Advisory: yawkat LZ4 Java: LZ4BlockInputStream allocates an unvalidated compressed length from the stream header
IDs: CVE-2026-106452, GHSA-4v53-57pg-c464
Record: https://patchnext.com/advisories/cve-2026-106452 (revision 2, source checked 26 Oct 2026, 16:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: at.yawk.lz4:lz4-java 1.11.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven at.yawk.lz4:lz4-java: affected <= 1.11.1; fixed in 1.11.2
- Maven org.lz4:lz4-java: affected <= 1.8.1

## Suggested inspection (read-only)
- Maven at.yawk.lz4:lz4-java: check the installed version with your package manager.
- Maven org.lz4:lz4-java: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on at.yawk.lz4:lz4-java, org.lz4:lz4-java.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4v53-57pg-c464 (OSV record GHSA-4v53-57pg-c464 lists affected ranges: Maven at.yawk.lz4:lz4-java >=0 =0 <=1.8.1)
- Verified: https://github.com/advisories/GHSA-4v53-57pg-c464 (GitHub-reviewed advisory GHSA-4v53-57pg-c464 lists affected ranges: Maven at.yawk.lz4:lz4-java >=0 =0 <=1.8.1)

Commands are suggestions: review each one before running it.

Loading voting…