Skip to content

← Actionable
High, CVSS 8.7amended

@stablelib/cbor: Stack exhaustion Denial of Service via deeply nested CBOR arrays, maps, or tags

CVE-2026-106447GHSA-5jg4-p4qw-cgfr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@stablelib/cbor 2.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-106447: 0.47% estimated exploitation activity in the next 30 days; percentile 40.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary @stablelib/cbor decodes nested CBOR structures recursively and does not enforce a maximum nesting depth. A sufficiently deep attacker-controlled CBOR payload can therefore crash decoding with RangeError: Maximum call stack size exceeded. Details The decoder processes arrays, maps, and tagged values through recursive calls. Each nested container causes another descent into decodeValue() until a leaf value is reached. There is no depth limit, no iterative fallback, and no protection against pathological nesting. An attacker can therefore supply a payload made of thousands of nested arrays, maps, or tags and force the decoder to recurse until the JavaScript call stack is exhausted. PoC Impact Any application that decodes attacker-controlled CBOR can be forced into a reliable denial of service with a single crafted payload. The immediate result is an exception during decoding. In services that do not catch that exception safely, the request fails and the worker or process…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5jg4-p4qw-cgfr

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5jg4-p4qw-cgfr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106447

Advisory: @stablelib/cbor: Stack exhaustion Denial of Service via deeply nested CBOR arrays, maps, or tags
IDs: CVE-2026-106447, GHSA-5jg4-p4qw-cgfr
Record: https://patchnext.com/advisories/cve-2026-106447 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @stablelib/cbor 2.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @stablelib/cbor: affected < 2.0.3; fixed in 2.0.3

## Suggested inspection (read-only)
- `npm ls @stablelib/cbor --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @stablelib/cbor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5jg4-p4qw-cgfr (OSV record GHSA-5jg4-p4qw-cgfr lists affected ranges: npm @stablelib/cbor >=0 <2.0.3 (fixed))
- Verified: https://github.com/advisories/GHSA-5jg4-p4qw-cgfr (GitHub-reviewed advisory GHSA-5jg4-p4qw-cgfr lists affected ranges: npm @stablelib/cbor >=0 <2.0.3)

Commands are suggestions: review each one before running it.

Loading voting…