Handlebars: JavaScript Injection via AST Type Confusion in compile (bypass of CVE-2026-33937)
CVE-2026-106446GHSA-8r5x-fm3f-whwj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (handlebars 4.7.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm handlebars
- Affected
- >= 4.0.0, <= 4.7.9
- Fixed in
- 4.7.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8r5x-fm3f-whwj lists affected ranges: npm handlebars >=4.0.0 <=4.7.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8r5x-fm3f-whwj lists affected ranges: npm handlebars >=4.0.0 <4.7.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-106446: 0.79% estimated exploitation activity in the next 30 days; percentile 56.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Handlebars.compile() and Handlebars.precompile() accept a pre-parsed AST as well as a template string. Handlebars 4.7.9 added validation for such ASTs. It only checks values on PathExpression, NumberLiteral and BooleanLiteral nodes, and the compiler still writes several other AST values into the generated JavaScript unchecked. If an application passes an untrusted object to compile() or precompile(), such as a parsed JSON request body, that object can carry arbitrary JavaScript. With compile(), the code runs on the server when the template renders. With precompile(), it ends up in the precompiled output and runs wherever that output is loaded. Applications that only ever pass template strings are not affected. This bypasses the AST validation added in 4.7.9 for GHSA-2w6w-674q-4c4q, GHSA-xhpv-hc6g-r9c6 and GHSA-3mfm-83xf-c92r. Details The 4.7.9 validator runs in parseWithoutProcessing() and walks the whole AST. It only checks values on nodes whose type is PathExpression,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8r5x-fm3f-whwj
- Revision 2 · amended ·
Amended from osv record GHSA-8r5x-fm3f-whwj
- Revision 1 · created ·
Published from ghsa record GHSA-8r5x-fm3f-whwj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-106446 Advisory: Handlebars: JavaScript Injection via AST Type Confusion in compile (bypass of CVE-2026-33937) IDs: CVE-2026-106446, GHSA-8r5x-fm3f-whwj Record: https://patchnext.com/advisories/cve-2026-106446 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: handlebars 4.7.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm handlebars: affected >= 4.0.0, <= 4.7.9; fixed in 4.7.10 ## Suggested inspection (read-only) - `npm ls handlebars --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on handlebars. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8r5x-fm3f-whwj (GitHub-reviewed advisory GHSA-8r5x-fm3f-whwj lists affected ranges: npm handlebars >=4.0.0 <=4.7.9) - Verified: https://osv.dev/vulnerability/GHSA-8r5x-fm3f-whwj (OSV record GHSA-8r5x-fm3f-whwj lists affected ranges: npm handlebars >=4.0.0 <4.7.10 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…