Skip to content

← Actionable
High, CVSS 8.8amended

WeasyPrint: EPS images reach the Ghostscript interpreter resulting in RCE

CVE-2026-106443GHSA-r543-q48m-4c9j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (weasyprint 70.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-106443: 0.92% estimated exploitation activity in the next 30 days; percentile 60.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary This was found during a pentest, funded by the NLNnet foundation, conducted by Stefan Vink from Radically Open Security and the only High issue found. WeasyPrint passes fetched image bytes directly to Pillow's generic format dispatcher without restricting the input format. When Ghostscript is installed on the host, Pillow's EpsImagePlugin invokes it to rasterize attacker-controlled EPS/PS input. Any content that can supply an image to WeasyPrint (an <img URL, CSS image value, SVG image reference, or data URI) can therefore drive untrusted PostScript into an external interpreter. On hosts running a Ghostscript version with a known -dSAFER bypass, this yields remote code execution. Details The image pipeline reads an external response and hands the raw bytes to Pillow's format-agnostic Image.open, with no allowlist of safe raster formats: with fetch(urlfetcher, url) as response: bytestring = response.read() mimetype = forcedmimetype or response.contenttype ... pillowimage =…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r543-q48m-4c9j

  2. Revision 2 · amended ·

    Amended from osv record GHSA-r543-q48m-4c9j

  3. Revision 1 · created ·

    Published from ghsa record GHSA-r543-q48m-4c9j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106443

Advisory: WeasyPrint: EPS images reach the Ghostscript interpreter resulting in RCE
IDs: CVE-2026-106443, GHSA-r543-q48m-4c9j
Record: https://patchnext.com/advisories/cve-2026-106443 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: weasyprint 70.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI weasyprint: affected <= 69.0; fixed in 70.0

## Suggested inspection (read-only)
- `python -m pip show weasyprint`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on weasyprint.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r543-q48m-4c9j (GitHub-reviewed advisory GHSA-r543-q48m-4c9j lists affected ranges: PyPI weasyprint >=0 <=69.0)
- Verified: https://osv.dev/vulnerability/GHSA-r543-q48m-4c9j (OSV record GHSA-r543-q48m-4c9j lists affected ranges: PyPI weasyprint >=0 <70.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…