Skip to content

← Actionable
High, CVSS 8.5

Hydra: Mutable instantiate policy sets allow target blocklist bypass

CVE-2026-106439GHSA-mwj6-rfh8-7qf4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (hydra-core 1.4.0.dev10, 1.3.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI hydra-core

    Affected
    >= 1.3.4, < 1.3.7>= 1.4.0.dev4, < 1.4.0.dev10
    Fixed in
    1.3.7, 1.4.0.dev10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.5 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-106439: 0.46% estimated exploitation activity in the next 30 days; percentile 39.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Hydra's legacy instantiate() target blocklists and related execution-policy collections are stored in mutable module-level state. Because locate() can resolve attributes on imported objects, a configuration can resolve a mutation method such as .discard(), modify the active policy, and then instantiate a target that would otherwise be blocked. Impact A configuration controlling multiple sibling target entries can first remove an entry from a target blocklist and then invoke the removed target. Sibling nodes are processed in insertion order and consult the same mutable module-level policy. This affects the legacy/default path without an execution whitelist. The 1.3 blocklist is a defense-in-depth measure rather than a complete security boundary, and applications must not treat arbitrary untrusted configuration as safe to instantiate or use for Python logging configuration. Released hydra-core versions 1.3.4 through 1.3.6 and 1.4.0.dev4 through 1.4.0.dev9 are affected. Fixed…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mwj6-rfh8-7qf4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106439

Advisory: Hydra: Mutable instantiate policy sets allow target blocklist bypass
IDs: CVE-2026-106439, GHSA-mwj6-rfh8-7qf4
Record: https://patchnext.com/advisories/cve-2026-106439 (revision 1, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: hydra-core 1.4.0.dev10, 1.3.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI hydra-core: affected >= 1.3.4, < 1.3.7; >= 1.4.0.dev4, < 1.4.0.dev10; fixed in 1.3.7, 1.4.0.dev10

## Suggested inspection (read-only)
- `python -m pip show hydra-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on hydra-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mwj6-rfh8-7qf4 (GitHub-reviewed advisory GHSA-mwj6-rfh8-7qf4 lists affected ranges: PyPI hydra-core >=1.3.4 =1.4.0.dev4 <1.4.0.dev10)

Commands are suggestions: review each one before running it.

Loading voting…