Skip to content

← Actionable
High, CVSS 8.2amended

MongoDB Python Driver: Out-of-bounds read in BSON decoding via a malformed Regex element

CVE-2026-106435GHSA-98qm-wvgf-w4cf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pymongo 4.18.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pymongo

    Affected
    >= 3.9.0, < 4.18.3
    Fixed in
    4.18.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-106435: 0.09% estimated exploitation activity in the next 30 days; percentile 0.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The C extension's BSON decoder scans a Regex element's pattern and flags strings with strlen before checking the document's remaining length, so a crafted truncated Regex element can read past the end of the caller's buffer. bson.decode and bson.decode_all accept mmap and array buffers, which carry no NUL sentinel; the read can cross into unmapped memory and kill the process with an uncatchable SIGSEGV. Any application decoding untrusted BSON from such buffers is affected — impact is availability only, since the out-of-bounds bytes are never returned as content. NUL-terminated buffers (bytes, bytearray) raise `InvalidBSON` at worst; the driver's own transport and pure-Python installs are not affected. All releases through 4.18.2 are affected when the C extension is loaded.

Patches Fixed in PyMongo 4.18.3. Malformed Regex elements now raise InvalidBSON on every accepted buffer type; valid documents decode unchanged.

Workarounds Decode untrusted BSON only from…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-98qm-wvgf-w4cf

  2. Revision 1 · created ·

    Published from ghsa record GHSA-98qm-wvgf-w4cf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106435

Advisory: MongoDB Python Driver: Out-of-bounds read in BSON decoding via a malformed Regex element
IDs: CVE-2026-106435, GHSA-98qm-wvgf-w4cf
Record: https://patchnext.com/advisories/cve-2026-106435 (revision 2, source checked 28 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pymongo 4.18.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pymongo: affected >= 3.9.0, < 4.18.3; fixed in 4.18.3

## Suggested inspection (read-only)
- `python -m pip show pymongo`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pymongo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-98qm-wvgf-w4cf (OSV record GHSA-98qm-wvgf-w4cf lists affected ranges: PyPI pymongo >=3.9.0 <4.18.3 (fixed))
- Verified: https://github.com/advisories/GHSA-98qm-wvgf-w4cf (GitHub-reviewed advisory GHSA-98qm-wvgf-w4cf lists affected ranges: PyPI pymongo >=3.9.0 <=4.18.2)

Commands are suggestions: review each one before running it.

Loading voting…