RabbitMQ: Malformed UTF-8 in shortstr properties permanently disables RPC consumers
CVE-2026-106122GHSA-7822-rcf6-97fx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.rabbitmq:amqp-client 5.36.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.rabbitmq:amqp-client
- Affected
- <= 5.35.0
- Fixed in
- 5.36.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7822-rcf6-97fx lists affected ranges: Maven com.rabbitmq:amqp-client >=0 <5.36.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7822-rcf6-97fx lists affected ranges: Maven com.rabbitmq:amqp-client >=0 <=5.35.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-106122: 0.49% estimated exploitation activity in the next 30 days; percentile 42.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A single AMQP message with malformed UTF-8 in a shortstr property (for example correlation-id) can permanently disable a Java client RPC consumer. The client decodes malformed bytes into U+FFFD replacement characters. Each of those re-encodes to 3 bytes, so a 255-byte property becomes 765 bytes (over the 255-byte shortstr limit). When the application echoes that value back, as the documented RPC pattern does, the encoder throws an unchecked IllegalArgumentException. That kills the consumer loop or tears down the channel. The message is never acknowledged, so the broker requeues it and it disables the next consumer that picks it up. Recovery does not help; the service stays down until an operator manually purges the queue. In short: the decoder produces values the encoder rejects, and any client permitted to use an RPC service can permanently destroy it for everyone. Details ValueReader.readShortstr decodes with new String(b, StandardCharsets.UTF8), which silently substitutes…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7822-rcf6-97fx
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7822-rcf6-97fx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-106122 Advisory: RabbitMQ: Malformed UTF-8 in shortstr properties permanently disables RPC consumers IDs: CVE-2026-106122, GHSA-7822-rcf6-97fx Record: https://patchnext.com/advisories/cve-2026-106122 (revision 3, source checked 26 Oct 2026, 16:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.rabbitmq:amqp-client 5.36.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.rabbitmq:amqp-client: affected <= 5.35.0; fixed in 5.36.0 ## Suggested inspection (read-only) - Maven com.rabbitmq:amqp-client: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.rabbitmq:amqp-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7822-rcf6-97fx (OSV record GHSA-7822-rcf6-97fx lists affected ranges: Maven com.rabbitmq:amqp-client >=0 <5.36.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7822-rcf6-97fx (GitHub-reviewed advisory GHSA-7822-rcf6-97fx lists affected ranges: Maven com.rabbitmq:amqp-client >=0 <=5.35.0) Commands are suggestions: review each one before running it.
Loading voting…