Skip to content

← Actionable
Medium, CVSS 6.0amended

LangChain: MongoDBChatMessageHistory query injection can allow cross-session access

CVE-2026-106119GHSA-m6rx-h84q-8r95

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@langchain/mongodb 1.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-106119: 0.46% estimated exploitation activity in the next 30 days; percentile 40.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact MongoDBChatMessageHistory did not enforce the documented string type for session identifiers at runtime. In affected applications, a structured session identifier could be interpreted as a MongoDB query condition rather than as a literal identifier. Applications are affected when they pass untrusted session identifier input to MongoDBChatMessageHistory and store multiple users’ histories in the same collection. An attacker who can invoke chat-history operations may be able to read, modify, or delete another user’s stored conversation. Applications that derive the session identifier from an authenticated, server-controlled value and enforce its type are not affected by this path. Patches The issue is fixed in @langchain/mongodb version 1.3.1. Users of affected versions should upgrade to version 1.3.1 or later. The patched version validates session identifiers at runtime and ensures they are compared as literal values in MongoDB queries. Workarounds If an immediate upgrade is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-m6rx-h84q-8r95

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-m6rx-h84q-8r95

  4. Revision 1 · created ·

    Published from ghsa record GHSA-m6rx-h84q-8r95

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106119

Advisory: LangChain: MongoDBChatMessageHistory query injection can allow cross-session access
IDs: CVE-2026-106119, GHSA-m6rx-h84q-8r95
Record: https://patchnext.com/advisories/cve-2026-106119 (revision 4, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @langchain/mongodb 1.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @langchain/mongodb: affected <= 1.3.0; fixed in 1.3.1

## Suggested inspection (read-only)
- `npm ls @langchain/mongodb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @langchain/mongodb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m6rx-h84q-8r95 (GitHub-reviewed advisory GHSA-m6rx-h84q-8r95 lists affected ranges: npm @langchain/mongodb >=0 <=1.3.0)
- Verified: https://osv.dev/vulnerability/GHSA-m6rx-h84q-8r95 (OSV record GHSA-m6rx-h84q-8r95 lists affected ranges: npm @langchain/mongodb >=0 <1.3.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…