ImageSharp: HistogramEqualization uses an unvalidated luminance as an unchecked histogram index
CVE-2026-106113GHSA-j3p4-wp97-rph4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sixlabors.imagesharp 4.1.2, 3.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet sixlabors.imagesharp
- Affected
- >= 2.0.0, < 3.2.0>= 4.0.0, < 4.1.2
- Fixed in
- 3.2.0, 4.1.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j3p4-wp97-rph4 lists affected ranges: NuGet sixlabors.imagesharp >=2.0.0 <4.1.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j3p4-wp97-rph4 lists affected ranges: NuGet sixlabors.imagesharp >=2.0.0 =4.0.0 <4.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j3p4-wp97-rph4 lists affected ranges: NuGet sixlabors.imagesharp >=2.0.0 =4.0.0 <4.1.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-106113: 0.39% estimated exploitation activity in the next 30 days; percentile 33.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary `SixLabors.ImageSharp` can terminate a process when an application decodes an attacker-supplied 32-bit floating-point TIFF as `Image ` and applies `HistogramEqualization()`. An IEEE positive-infinity TIFF sample reaches a non-finite or otherwise out-of-range `HalfVector4` component, depending on the release. The histogram equalization path derives a luminance-based histogram index without validating that result, reaching an unsafe out-of-range access. This report covers `HistogramEqualization` only. It does not claim Adaptive Histogram Equalization or AutoLevel behavior.
Affected package and versions - Package: `SixLabors.ImageSharp` (NuGet) - Affected range: `>= 2.0.0, Fatal error. System.AccessViolationException: Attempted to read or write protected memory. ... at SixLabors.ImageSharp.Processing.Processors.Normalization.GrayscaleLevelsRowOperation`1.Invoke ... at SixLabors.ImageSharp.Processing.HistogramEqualizationExtensions.HistogramEqualization Docker exit…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from osv record GHSA-j3p4-wp97-rph4
- Revision 3 · amended ·
Amended from ghsa record GHSA-j3p4-wp97-rph4
- Revision 2 · amended ·
Amended from ghsa record GHSA-j3p4-wp97-rph4
- Revision 1 · created ·
Published from osv record GHSA-j3p4-wp97-rph4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-106113 Advisory: ImageSharp: HistogramEqualization uses an unvalidated luminance as an unchecked histogram index IDs: CVE-2026-106113, GHSA-j3p4-wp97-rph4 Record: https://patchnext.com/advisories/cve-2026-106113 (revision 4, source checked 27 Oct 2026, 06:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sixlabors.imagesharp 4.1.2, 3.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet sixlabors.imagesharp: affected >= 2.0.0, < 3.2.0; >= 4.0.0, < 4.1.2; fixed in 3.2.0, 4.1.2 ## Suggested inspection (read-only) - NuGet sixlabors.imagesharp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sixlabors.imagesharp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j3p4-wp97-rph4 (OSV record GHSA-j3p4-wp97-rph4 lists affected ranges: NuGet sixlabors.imagesharp >=2.0.0 <4.1.2 (fixed)) - Verified: https://github.com/advisories/GHSA-j3p4-wp97-rph4 (GitHub-reviewed advisory GHSA-j3p4-wp97-rph4 lists affected ranges: NuGet sixlabors.imagesharp >=2.0.0 =4.0.0 <4.1.2) - Verified: https://osv.dev/vulnerability/GHSA-j3p4-wp97-rph4 (OSV record GHSA-j3p4-wp97-rph4 lists affected ranges: NuGet sixlabors.imagesharp >=2.0.0 =4.0.0 <4.1.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…