Skip to content

← Actionable
High, CVSS 8.3amended

Quasar Framework: App Vite SSR and SSG nonce attributes are not safely constrained

CVE-2026-106107GHSA-5m6h-8g35-p3m7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@quasar/app-vite 3.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-106107: 0.27% estimated exploitation activity in the next 30 days; percentile 18.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Several @quasar/app-vite SSR and SSG renderer paths interpolate ssrContext.nonce directly into quoted HTML attributes. An application that derives or overrides the nonce using untrusted data can allow a quote to terminate the nonce attribute and inject additional attributes or markup into generated HTML. Cryptographically generated base64 or base64url nonces are not directly affected because they do not contain HTML attribute delimiters. Exploitation requires an application to place attacker-controlled or otherwise unsafe data in ssrContext.nonce. The remediation centralizes nonce handling across development SSR/SSG, production SSR, production SSG, critical CSS, store-state scripts, and Vue Devtools. It validates the value as a non-empty base64/base64url CSP nonce and HTML-encodes the attribute value before rendering.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-5m6h-8g35-p3m7

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-5m6h-8g35-p3m7

  4. Revision 1 · created ·

    Published from ghsa record GHSA-5m6h-8g35-p3m7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106107

Advisory: Quasar Framework: App Vite SSR and SSG nonce attributes are not safely constrained
IDs: CVE-2026-106107, GHSA-5m6h-8g35-p3m7
Record: https://patchnext.com/advisories/cve-2026-106107 (revision 4, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @quasar/app-vite 3.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @quasar/app-vite: affected <= 3.2.0; fixed in 3.3.0

## Suggested inspection (read-only)
- `npm ls @quasar/app-vite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @quasar/app-vite.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5m6h-8g35-p3m7 (GitHub-reviewed advisory GHSA-5m6h-8g35-p3m7 lists affected ranges: npm @quasar/app-vite >=0 <=3.2.0)
- Verified: https://osv.dev/vulnerability/GHSA-5m6h-8g35-p3m7 (OSV record GHSA-5m6h-8g35-p3m7 lists affected ranges: npm @quasar/app-vite >=0 <3.3.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…