Skip to content

← Actionable
High, CVSS 7.1amended

Quasar Framework: SSR/SSG dev error page discloses the full shell environment and its escape is bypassable

CVE-2026-106106GHSA-r5mf-4r5x-q78f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@quasar/render-ssr-error 2.2.4; @quasar/app-vite 3.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:P/VC:H/VI:L/VA:N/SC:H/SI:H/SA:N · score source
EPSS
  • CVE-2026-106106: 0.28% estimated exploitation activity in the next 30 days; percentile 20.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The error page that Quasar CLI shows when an SSR or SSG render throws in development serializes every variable in process.env, every request header and every cookie into the HTTP response, and the dev server binds 0.0.0.0 by default. Any host that can reach the port therefore gets the developer's cloud keys, registry tokens and database URLs from a single unauthenticated GET. The same page embeds that data inside a <script element behind a replaceAll('</script', ...) guard that is ASCII-case-sensitive and requires a literal , so </SCRIPT, </script and </script/ all escape the element and give script execution in the dev server's origin. Details renderSSRError() builds the page by splicing a JSON blob into a prebuilt bundle (utils/render-ssr-error/src/index.js): before and after are the two halves of the compiled error-page UI, split inside a <script type="module" element, so data is emitted as a JS object literal in raw script text. The data itself comes from…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-r5mf-4r5x-q78f

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-r5mf-4r5x-q78f

  4. Revision 1 · created ·

    Published from ghsa record GHSA-r5mf-4r5x-q78f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106106

Advisory: Quasar Framework: SSR/SSG dev error page discloses the full shell environment and its escape is bypassable
IDs: CVE-2026-106106, GHSA-r5mf-4r5x-q78f
Record: https://patchnext.com/advisories/cve-2026-106106 (revision 4, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @quasar/render-ssr-error 2.2.4; @quasar/app-vite 3.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @quasar/render-ssr-error: affected <= 2.2.3; fixed in 2.2.4
- npm @quasar/app-vite: affected <= 3.2.0; fixed in 3.3.0

## Suggested inspection (read-only)
- `npm ls @quasar/render-ssr-error --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @quasar/app-vite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @quasar/render-ssr-error, @quasar/app-vite.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r5mf-4r5x-q78f (GitHub-reviewed advisory GHSA-r5mf-4r5x-q78f lists affected ranges: npm @quasar/render-ssr-error >=0 =0 <=3.2.0)
- Verified: https://osv.dev/vulnerability/GHSA-r5mf-4r5x-q78f (OSV record GHSA-r5mf-4r5x-q78f lists affected ranges: npm @quasar/render-ssr-error >=0 =0 <3.3.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…