Skip to content

← Actionable
High, CVSS 8.7amended

Quasar Framework: Super-linear regex backtracking on User-Agent lets one request stall a Quasar SSR server

CVE-2026-106104GHSA-68jq-fhch-4xq4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (quasar 2.23.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm quasar

    Affected
    <= 2.23.2
    Fixed in
    2.23.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-106104: 0.37% estimated exploitation activity in the next 30 days; percentile 31.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary One unauthenticated request with a crafted User-Agent stalls a Quasar SSR server for seconds. Quasar auto-installs its Platform plugin on every server-side render, and Platform.parseSSR() feeds the raw, unbounded User-Agent request header into a chain of backtracking regular expressions in getMatch(). One of those patterns contains a greedy capture followed by two unbounded . scans, so a crafted header costs time proportional to the cube of its length. An 8 KB User-Agent blocks the Node.js event loop for about 4.4 seconds, and a 16 KB one for about 35 seconds. During that time the server answers nobody, so a handful of tiny requests take an SSR site completely offline. Details Platform is in the autoInstalledPlugins array in ui/src/install-quasar.js, so it is installed unconditionally by app.use(Quasar, ...). The generated SSR entry (app-vite/templates/entry/app.js, called from app-vite/templates/entry/server-entry.js) runs that for every HTTP request, and it runs before…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-68jq-fhch-4xq4

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-68jq-fhch-4xq4

  4. Revision 1 · created ·

    Published from ghsa record GHSA-68jq-fhch-4xq4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106104

Advisory: Quasar Framework: Super-linear regex backtracking on User-Agent lets one request stall a Quasar SSR server
IDs: CVE-2026-106104, GHSA-68jq-fhch-4xq4
Record: https://patchnext.com/advisories/cve-2026-106104 (revision 4, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: quasar 2.23.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm quasar: affected <= 2.23.2; fixed in 2.23.3

## Suggested inspection (read-only)
- `npm ls quasar --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on quasar.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-68jq-fhch-4xq4 (GitHub-reviewed advisory GHSA-68jq-fhch-4xq4 lists affected ranges: npm quasar >=0 <=2.23.2)
- Verified: https://osv.dev/vulnerability/GHSA-68jq-fhch-4xq4 (OSV record GHSA-68jq-fhch-4xq4 lists affected ranges: npm quasar >=0 <2.23.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…