Skip to content

← Actionable
Critical, CVSS 10.0amended

Quasar Framework: Stored/Reflected XSS via unescaped SSR meta tag rendering in getHead()

CVE-2026-106102GHSA-pq96-jpmf-w254

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (quasar 2.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm quasar

    Affected
    < 2.22.0
    Fixed in
    2.22.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-106102: 0.30% estimated exploitation activity in the next 30 days; percentile 22.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability Details File: ui/src/utils/meta/Meta.js — actually ui/src/plugins/meta/Meta.js (lines 149-176: getAttr() and getHead()) Sink: injectServerMeta() (same file) → ctx.headTags += getHead(data), interpolated verbatim into the raw HTTP response <head by the production SSR template (app-vite/templates/entry/ssr-prod-webserver.js + app-vite/lib/plugins/vite.html.js) Entry point: the public useMeta() composable (ui/src/composables/use-meta/use-meta.js) — the single documented way apps set page title/meta/link/script tags Root Cause getHead() is Quasar's SSR-only serializer that turns the meta/link/script/title data collected from every useMeta() call into a literal HTML string, using plain template-literal interpolation with zero HTML-entity escaping and zero attribute-quote escaping: Contrast this with the client-side equivalent, apply() (same file, used only in the browser post-hydration), which builds the same tags via document.createElement(...) + tag.setAttribute(att, val)…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-pq96-jpmf-w254

  2. Revision 2 · amended ·

    Amended from osv record GHSA-pq96-jpmf-w254

  3. Revision 1 · created ·

    Published from ghsa record GHSA-pq96-jpmf-w254

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106102

Advisory: Quasar Framework: Stored/Reflected XSS via unescaped SSR meta tag rendering in getHead()
IDs: CVE-2026-106102, GHSA-pq96-jpmf-w254
Record: https://patchnext.com/advisories/cve-2026-106102 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: quasar 2.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm quasar: affected < 2.22.0; fixed in 2.22.0

## Suggested inspection (read-only)
- `npm ls quasar --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on quasar.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pq96-jpmf-w254 (GitHub-reviewed advisory GHSA-pq96-jpmf-w254 lists affected ranges: npm quasar >=0 <2.22.0)
- Verified: https://osv.dev/vulnerability/GHSA-pq96-jpmf-w254 (OSV record GHSA-pq96-jpmf-w254 lists affected ranges: npm quasar >=0 <2.22.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…