Quasar Framework: DOM Clobbering in Quasar openURL() SafariViewController Integration Causes Client-Side Denial of Service
CVE-2026-106101GHSA-89vp-x45c-52cq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (quasar 2.32.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm quasar
- Affected
- <= 2.32.1
- Fixed in
- 2.32.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-89vp-x45c-52cq lists affected ranges: npm quasar >=0 <=2.32.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-89vp-x45c-52cq lists affected ranges: npm quasar >=0 <2.32.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-106101: 0.26% estimated exploitation activity in the next 30 days; percentile 17.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A DOM Clobbering vulnerability exists in Quasar's openURL() utility when handling the iOS SafariViewController bridge. The vulnerable implementation only checks whether window.SafariViewController exists before invoking it as a native bridge object. An attacker who can inject HTML content containing a named element such as <a id="SafariViewController" can cause the browser to expose that element as window.SafariViewController. When openURL() is later called in an iOS environment, Quasar incorrectly treats the DOM element as the native bridge object and attempts to invoke bridge methods that do not exist, resulting in: This can cause client-side denial of service and break navigation-related workflows in Quasar applications. Details Quasar provides the openURL() utility to open external URLs. On iOS platforms, this utility supports integration with the native SafariViewController bridge. The vulnerable code is located in: The affected logic is: The issue is that Quasar only…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-89vp-x45c-52cq
- Revision 2 · amended ·
Amended from osv record GHSA-89vp-x45c-52cq
- Revision 1 · created ·
Published from ghsa record GHSA-89vp-x45c-52cq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-106101 Advisory: Quasar Framework: DOM Clobbering in Quasar openURL() SafariViewController Integration Causes Client-Side Denial of Service IDs: CVE-2026-106101, GHSA-89vp-x45c-52cq Record: https://patchnext.com/advisories/cve-2026-106101 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: quasar 2.32.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm quasar: affected <= 2.32.1; fixed in 2.32.2 ## Suggested inspection (read-only) - `npm ls quasar --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on quasar. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-89vp-x45c-52cq (GitHub-reviewed advisory GHSA-89vp-x45c-52cq lists affected ranges: npm quasar >=0 <=2.32.1) - Verified: https://osv.dev/vulnerability/GHSA-89vp-x45c-52cq (OSV record GHSA-89vp-x45c-52cq lists affected ranges: npm quasar >=0 <2.32.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…