Skip to content

← Actionable
Unratedamended

Improper certificate validation for non-canonical IPv4 hostnames allows DNS SANs to authenticate IP endpoints

CVE-2026-106072

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-min 26.12.1, 24.22.1, 22.23.4; node 26.12.1, 24.22.1, 22.23.4; node 26.12.1, 24.22.1, 22.23.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Bitnami node-min

    Affected
    < 22.23.4>= 23.0.0, < 24.22.1>= 25.0.0, < 26.12.1
    Fixed in
    26.12.1, 22.23.4, 24.22.1
  • runtime node

    Affected
    >= 22.0.0, < 22.23.4>= 24.0.0, < 24.22.1>= 26.0.0, < 26.12.1
    Fixed in
    26.12.1, 22.23.4, 24.22.1
  • Bitnami node

    Affected
    < 22.23.4>= 23.0.0, < 24.22.1>= 25.0.0, < 26.12.1
    Fixed in
    26.12.1, 22.23.4, 24.22.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-106072: 0.62% estimated exploitation activity in the next 30 days; percentile 49.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw in Node.js TLS hostname verification allows a certificate with only a DNS SAN to authenticate an IP endpoint when the client connects using a non-canonical IPv4 spelling, such as `0177.0.0.1`, `0x7f.0.0.1`, `2130706433` or `127.1`. `tls.checkServerIdentity()` did not classify these hosts as IP addresses, but normalized them to their canonical form and matched the result against the certificate DNS names. A certificate containing `DNS:127.0.0.1` and no `IP Address:127.0.0.1` SAN was therefore accepted, while the same certificate is correctly rejected for `127.0.0.1`. Exploitation requires a certificate with a numeric DNS SAN issued by a CA trusted by the client, and a platform resolver that accepts these spellings, such as glibc. This vulnerability affects Node.js 26.x, 24.x, and 22.x.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record BIT-node-min-2026-106072

  2. Revision 2 · amended ·

    Amended from osv record BIT-node-2026-106072

  3. Revision 1 · created ·

    Published from vendor_advisory record nodejs-security-wg:core:201

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106072

Advisory: Improper certificate validation for non-canonical IPv4 hostnames allows DNS SANs to authenticate IP endpoints
IDs: CVE-2026-106072
Record: https://patchnext.com/advisories/cve-2026-106072 (revision 3, source checked 30 Oct 2026, 07:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: node-min 26.12.1, 24.22.1, 22.23.4; node 26.12.1, 24.22.1, 22.23.4; node 26.12.1, 24.22.1, 22.23.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Bitnami node-min: affected < 22.23.4; >= 23.0.0, < 24.22.1; >= 25.0.0, < 26.12.1; fixed in 26.12.1, 22.23.4, 24.22.1
- runtime node: affected >= 22.0.0, < 22.23.4; >= 24.0.0, < 24.22.1; >= 26.0.0, < 26.12.1; fixed in 26.12.1, 22.23.4, 24.22.1
- Bitnami node: affected < 22.23.4; >= 23.0.0, < 24.22.1; >= 25.0.0, < 26.12.1; fixed in 26.12.1, 22.23.4, 24.22.1

## Suggested inspection (read-only)
- Bitnami node-min: check the installed version with your package manager.
- runtime node: check the installed version with your package manager.
- Bitnami node: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node-min, node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/201.json (Node.js security working group core entry 201 lists CVE-2026-106072 affecting node >=22.0.0 =24.0.0 =26.0.0 <26.12.1)
- Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2026-106072 to 2026-10-20.)
- Verified: https://osv.dev/vulnerability/BIT-node-min-2026-106072 (OSV record BIT-node-min-2026-106072 lists affected ranges: Bitnami node-min >=0 =23.0.0 =25.0.0 <26.12.1 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-node-2026-106072 (OSV record BIT-node-2026-106072 lists affected ranges: Bitnami node >=0 =23.0.0 =25.0.0 <26.12.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…