Skip to content

← Actionable
Unratedamended

Permission Model filesystem over-grant via wildcard radix lookup

CVE-2026-106071

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-min 26.12.1; node 26.12.1; node 26.12.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Bitnami node-min

    Affected
    >= 25.0.0, < 26.12.1
    Fixed in
    26.12.1
  • runtime node

    Affected
    >= 26.0.0, < 26.12.1
    Fixed in
    26.12.1
  • Bitnami node

    Affected
    >= 25.0.0, < 26.12.1
    Fixed in
    26.12.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-106071: 0.20% estimated exploitation activity in the next 30 days; percentile 9.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw in Node.js Permission Model filesystem enforcement can grant access to paths that do not match a wildcard `--allow-fs-read` or `--allow-fs-write` rule. When the requested path is shorter than the prefix of a wildcard grant, the radix tree lookup stops comparing early and treats the path as a match. For example, `--allow-fs-read=/etc/passwd.*` also allows reading `/etc/passwd`. This requires the wildcard grant to sit directly under the root of the permission tree, for example when it is the only grant for that scope. This is a different root cause from CVE-2026-58043. This vulnerability affects Node.js 26.x.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record BIT-node-min-2026-106071

  2. Revision 2 · amended ·

    Amended from osv record BIT-node-2026-106071

  3. Revision 1 · created ·

    Published from vendor_advisory record nodejs-security-wg:core:200

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106071

Advisory: Permission Model filesystem over-grant via wildcard radix lookup
IDs: CVE-2026-106071
Record: https://patchnext.com/advisories/cve-2026-106071 (revision 3, source checked 30 Oct 2026, 07:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: node-min 26.12.1; node 26.12.1; node 26.12.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Bitnami node-min: affected >= 25.0.0, < 26.12.1; fixed in 26.12.1
- runtime node: affected >= 26.0.0, < 26.12.1; fixed in 26.12.1
- Bitnami node: affected >= 25.0.0, < 26.12.1; fixed in 26.12.1

## Suggested inspection (read-only)
- Bitnami node-min: check the installed version with your package manager.
- runtime node: check the installed version with your package manager.
- Bitnami node: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node-min, node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2026-106071 to 2026-10-21.)
- Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/200.json (Node.js security working group core entry 200 lists CVE-2026-106071 affecting node >=26.0.0 <26.12.1)
- Verified: https://osv.dev/vulnerability/BIT-node-2026-106071 (OSV record BIT-node-2026-106071 lists affected ranges: Bitnami node >=25.0.0 <26.12.1 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-node-min-2026-106071 (OSV record BIT-node-min-2026-106071 lists affected ranges: Bitnami node-min >=25.0.0 <26.12.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…