TLS certificate hostname bypass when the host loosely resolves to an IP address
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-min 26.12.1, 24.22.1, 22.23.4; node 26.12.1, 24.22.1, 22.23.4; node 26.12.1, 24.22.1, 22.23.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Bitnami node-min
- Affected
- < 22.23.4>= 23.0.0, < 24.22.1>= 25.0.0, < 26.12.1
- Fixed in
- 26.12.1, 22.23.4, 24.22.1
runtime node
- Affected
- >= 22.0.0, < 22.23.4>= 24.0.0, < 24.22.1>= 26.0.0, < 26.12.1
- Fixed in
- 26.12.1, 22.23.4, 24.22.1
Bitnami node
- Affected
- < 22.23.4>= 23.0.0, < 24.22.1>= 25.0.0, < 26.12.1
- Fixed in
- 26.12.1, 22.23.4, 24.22.1
Sources
- raw.githubusercontent.com runtime security intelligence
Node.js security working group core entry 198 lists CVE-2026-106069 affecting node >=22.0.0 =24.0.0 =26.0.0 <26.12.1
VerifiedObserved Authoritative source for Node.js core CVEs: structured Node.js security-wg core vulnerability record maintained by the Node.js project.
- nodejs.org runtime security intelligence
The nodejs.org release index dates the first patched release for CVE-2026-106069 to 2026-10-20.
VerifiedObserved Official nodejs.org release index (dist/index.json).
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-node-2026-106069 lists affected ranges: Bitnami node >=0 =23.0.0 =25.0.0 <26.12.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-node-min-2026-106069 lists affected ranges: Bitnami node-min >=0 =23.0.0 =25.0.0 <26.12.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-106069: 0.30% estimated exploitation activity in the next 30 days; percentile 23.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw in Node.js TLS hostname verification can cause a server certificate to be validated against a different IP address than the one the client connected to, when the host is a non-canonical IPv4 literal with a leading zero, such as `0127.0.0.1`. `tls.checkServerIdentity()` normalizes the host following the WHATWG URL rules, which read a leading-zero octet as octal (`0127.0.0.1` becomes `87.0.0.1`), while the connection is made through the operating system resolver, which on some platforms such as macOS reads it as decimal (`127.0.0.1`). A server at the connected address can then be authenticated with a certificate issued for another IP address. This vulnerability affects Node.js 26.x, 24.x, and 22.x.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record BIT-node-min-2026-106069
- Revision 2 · amended ·
Amended from osv record BIT-node-2026-106069
- Revision 1 · created ·
Published from vendor_advisory record nodejs-security-wg:core:198
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-106069 Advisory: TLS certificate hostname bypass when the host loosely resolves to an IP address IDs: CVE-2026-106069 Record: https://patchnext.com/advisories/cve-2026-106069 (revision 3, source checked 30 Oct 2026, 07:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node-min 26.12.1, 24.22.1, 22.23.4; node 26.12.1, 24.22.1, 22.23.4; node 26.12.1, 24.22.1, 22.23.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Bitnami node-min: affected < 22.23.4; >= 23.0.0, < 24.22.1; >= 25.0.0, < 26.12.1; fixed in 26.12.1, 22.23.4, 24.22.1 - runtime node: affected >= 22.0.0, < 22.23.4; >= 24.0.0, < 24.22.1; >= 26.0.0, < 26.12.1; fixed in 26.12.1, 22.23.4, 24.22.1 - Bitnami node: affected < 22.23.4; >= 23.0.0, < 24.22.1; >= 25.0.0, < 26.12.1; fixed in 26.12.1, 22.23.4, 24.22.1 ## Suggested inspection (read-only) - Bitnami node-min: check the installed version with your package manager. - runtime node: check the installed version with your package manager. - Bitnami node: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node-min, node. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/198.json (Node.js security working group core entry 198 lists CVE-2026-106069 affecting node >=22.0.0 =24.0.0 =26.0.0 <26.12.1) - Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2026-106069 to 2026-10-20.) - Verified: https://osv.dev/vulnerability/BIT-node-2026-106069 (OSV record BIT-node-2026-106069 lists affected ranges: Bitnami node >=0 =23.0.0 =25.0.0 <26.12.1 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-node-min-2026-106069 (OSV record BIT-node-min-2026-106069 lists affected ranges: Bitnami node-min >=0 =23.0.0 =25.0.0 <26.12.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…