Skip to content

← Actionable
High, CVSS 8.6amended

Payload: Uploaded XML files could execute same-origin JavaScript

CVE-2026-105868GHSA-9qpg-3cf8-w33x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (payload 4.0.0-canary.34, 3.90.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm payload

    Affected
    < 3.90.0>= 4.0.0-canary.0, < 4.0.0-canary.34
    Fixed in
    4.0.0-canary.34, 3.90.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-105868: 0.17% estimated exploitation activity in the next 30 days; percentile 5.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Under certain local upload configurations, an uploaded XML file and stylesheet could execute JavaScript in the Payload origin when a logged-in user opens the file. You are affected if: - You accept XML uploads (accepted by default). Patches Users should upgrade Payload packages to = 3.90.0 or = 4.0.0-canary.34. Workarounds Disallow XML/XSL uploads.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-9qpg-3cf8-w33x

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-9qpg-3cf8-w33x

  4. Revision 1 · created ·

    Published from ghsa record GHSA-9qpg-3cf8-w33x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-105868

Advisory: Payload: Uploaded XML files could execute same-origin JavaScript
IDs: CVE-2026-105868, GHSA-9qpg-3cf8-w33x
Record: https://patchnext.com/advisories/cve-2026-105868 (revision 4, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: payload 4.0.0-canary.34, 3.90.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm payload: affected < 3.90.0; >= 4.0.0-canary.0, < 4.0.0-canary.34; fixed in 4.0.0-canary.34, 3.90.0

## Suggested inspection (read-only)
- `npm ls payload --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on payload.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9qpg-3cf8-w33x (GitHub-reviewed advisory GHSA-9qpg-3cf8-w33x lists affected ranges: npm payload >=0 =4.0.0-canary.0 <4.0.0-canary.34)
- Verified: https://osv.dev/vulnerability/GHSA-9qpg-3cf8-w33x (OSV record GHSA-9qpg-3cf8-w33x lists affected ranges: npm payload >=0 =4.0.0-canary.0 <4.0.0-canary.34 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…