Payload: Client uploads could overwrite S3 objects
CVE-2026-105867GHSA-7vg8-29qx-jgj8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@payloadcms/storage-s3 4.0.0-canary.34, 3.90.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 3.90.0>= 4.0.0-canary.0, < 4.0.0-canary.34
- Fixed in
- 4.0.0-canary.34, 3.90.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7vg8-29qx-jgj8 lists affected ranges: npm @payloadcms/storage-s3 >=0 =4.0.0-canary.0 <4.0.0-canary.34
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7vg8-29qx-jgj8 lists affected ranges: npm @payloadcms/storage-s3 >=0 =4.0.0-canary.0 <4.0.0-canary.34 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-105867: 0.22% estimated exploitation activity in the next 30 days; percentile 12.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An authenticated user could overwrite an existing S3 object belonging to another upload collection, bypassing that collection’s access controls and prior file validation. You are affected if ALL of these are true: - Client uploads are enabled for multiple collections that share an S3 bucket. - useCompositePrefixes is not configured or is set to false. Patches Users should upgrade Payload packages to = 3.90.0 or = 4.0.0-canary.34. Workarounds Disable client uploads until you can upgrade.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-7vg8-29qx-jgj8
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-7vg8-29qx-jgj8
- Revision 1 · created ·
Published from ghsa record GHSA-7vg8-29qx-jgj8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-105867 Advisory: Payload: Client uploads could overwrite S3 objects IDs: CVE-2026-105867, GHSA-7vg8-29qx-jgj8 Record: https://patchnext.com/advisories/cve-2026-105867 (revision 4, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @payloadcms/storage-s3 4.0.0-canary.34, 3.90.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @payloadcms/storage-s3: affected < 3.90.0; >= 4.0.0-canary.0, < 4.0.0-canary.34; fixed in 4.0.0-canary.34, 3.90.0 ## Suggested inspection (read-only) - `npm ls @payloadcms/storage-s3 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @payloadcms/storage-s3. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7vg8-29qx-jgj8 (GitHub-reviewed advisory GHSA-7vg8-29qx-jgj8 lists affected ranges: npm @payloadcms/storage-s3 >=0 =4.0.0-canary.0 <4.0.0-canary.34) - Verified: https://osv.dev/vulnerability/GHSA-7vg8-29qx-jgj8 (OSV record GHSA-7vg8-29qx-jgj8 lists affected ranges: npm @payloadcms/storage-s3 >=0 =4.0.0-canary.0 <4.0.0-canary.34 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…