Payload external upload trust validation issue
CVE-2026-105861GHSA-pj5h-5q6c-3pfx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (payload 4.0.0-canary.34, 3.90.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm payload
- Affected
- >= 3.0.0, < 3.90.0>= 4.0.0-canary.0, < 4.0.0-canary.34
- Fixed in
- 4.0.0-canary.34, 3.90.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pj5h-5q6c-3pfx lists affected ranges: npm payload >=3.0.0 =4.0.0-canary.0 <4.0.0-canary.34
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pj5h-5q6c-3pfx lists affected ranges: npm payload >=3.0.0 =4.0.0-canary.0 <4.0.0-canary.34 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-105861: 0.13% estimated exploitation activity in the next 30 days; percentile 2.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Under certain external upload configurations, Payload could send authentication data to a destination that was not verified as trusted. If the affected request contained a valid session, this could expose that session to an unintended recipient. You are affected if: - You have enabled external URL-based upload retrieval, where authenticated requests can trigger it. Patches Payload now validates the destination before forwarding authentication data and reapplies that validation when a request changes destination. Users should upgrade Payload packages to = 3.90.0 or = 4.0.0-canary.34. Workarounds It is recommended to update all Payload packages to = 3.90.0 or = 4.0.0-canary.34. If you cannot, a valid workaround exists: - Disable external URL-based upload retrieval where practical. - If you cannot disable it, configure the upload header filter to remove authentication data from outbound file requests. - Restrict access to the affected upload functionality.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-pj5h-5q6c-3pfx
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-pj5h-5q6c-3pfx
- Revision 1 · created ·
Published from ghsa record GHSA-pj5h-5q6c-3pfx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-105861 Advisory: Payload external upload trust validation issue IDs: CVE-2026-105861, GHSA-pj5h-5q6c-3pfx Record: https://patchnext.com/advisories/cve-2026-105861 (revision 4, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: payload 4.0.0-canary.34, 3.90.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm payload: affected >= 3.0.0, < 3.90.0; >= 4.0.0-canary.0, < 4.0.0-canary.34; fixed in 4.0.0-canary.34, 3.90.0 ## Suggested inspection (read-only) - `npm ls payload --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on payload. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pj5h-5q6c-3pfx (GitHub-reviewed advisory GHSA-pj5h-5q6c-3pfx lists affected ranges: npm payload >=3.0.0 =4.0.0-canary.0 <4.0.0-canary.34) - Verified: https://osv.dev/vulnerability/GHSA-pj5h-5q6c-3pfx (OSV record GHSA-pj5h-5q6c-3pfx lists affected ranges: npm payload >=3.0.0 =4.0.0-canary.0 <4.0.0-canary.34 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…