Payload has a tenant authorization bypass in Multi-Tenant Plugin
CVE-2026-105860GHSA-p96c-xwx8-3cqj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@payloadcms/plugin-multi-tenant 4.0.0-canary.34, 3.90.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @payloadcms/plugin-multi-tenant
- Affected
- < 3.90.0>= 4.0.0-canary.0, < 4.0.0-canary.34
- Fixed in
- 4.0.0-canary.34, 3.90.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p96c-xwx8-3cqj lists affected ranges: npm @payloadcms/plugin-multi-tenant >=0 =4.0.0-canary.0 <4.0.0-canary.34
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p96c-xwx8-3cqj lists affected ranges: npm @payloadcms/plugin-multi-tenant >=0 =4.0.0-canary.0 <4.0.0-canary.34 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-105860: 0.19% estimated exploitation activity in the next 30 days; percentile 9.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When using the default tenant array field access, an authenticated user could assign themselves to other tenants. You are affected if: - You are using @payloadcms/plugin-multi-tenant If you configure the tenants arrayFieldAccess.create/update functions, a secured replacement membership field, you are not affected by this specific default behavior. Patches Users should upgrade Payload packages to = 3.90.0 or = 4.0.0-canary.34. Workarounds Configure tenants arrayFieldAccess.create and tenants arrayFieldAccess.update so only trusted users authorized for all tenants can modify memberships.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-p96c-xwx8-3cqj
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-p96c-xwx8-3cqj
- Revision 1 · created ·
Published from ghsa record GHSA-p96c-xwx8-3cqj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-105860 Advisory: Payload has a tenant authorization bypass in Multi-Tenant Plugin IDs: CVE-2026-105860, GHSA-p96c-xwx8-3cqj Record: https://patchnext.com/advisories/cve-2026-105860 (revision 4, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @payloadcms/plugin-multi-tenant 4.0.0-canary.34, 3.90.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @payloadcms/plugin-multi-tenant: affected < 3.90.0; >= 4.0.0-canary.0, < 4.0.0-canary.34; fixed in 4.0.0-canary.34, 3.90.0 ## Suggested inspection (read-only) - `npm ls @payloadcms/plugin-multi-tenant --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @payloadcms/plugin-multi-tenant. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p96c-xwx8-3cqj (GitHub-reviewed advisory GHSA-p96c-xwx8-3cqj lists affected ranges: npm @payloadcms/plugin-multi-tenant >=0 =4.0.0-canary.0 <4.0.0-canary.34) - Verified: https://osv.dev/vulnerability/GHSA-p96c-xwx8-3cqj (OSV record GHSA-p96c-xwx8-3cqj lists affected ranges: npm @payloadcms/plugin-multi-tenant >=0 =4.0.0-canary.0 <4.0.0-canary.34 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…