Skip to content

← Actionable
Critical, CVSS 9.8amended

Payload: Unauthorized update to collection documents

CVE-2026-105859GHSA-f7hx-52q9-hcrf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (payload 4.0.0-canary.34, 3.90.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm payload

    Affected
    < 3.90.0>= 4.0.0-canary.0, < 4.0.0-canary.34
    Fixed in
    4.0.0-canary.34, 3.90.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-105859: 0.35% estimated exploitation activity in the next 30 days; percentile 28.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker can submit a request to a specific endpoint that permits collection documents to be updated regardless of access control and field level access control. You are affected if: - You are configuring orderable: true with any collection or join field. Patches In the patched version access control is properly enforced. Users should upgrade Payload packages to = 3.90.0 or = 4.0.0-canary.34.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-f7hx-52q9-hcrf

  2. Revision 2 · amended ·

    Amended from osv record GHSA-f7hx-52q9-hcrf

  3. Revision 1 · created ·

    Published from ghsa record GHSA-f7hx-52q9-hcrf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-105859

Advisory: Payload: Unauthorized update to collection documents
IDs: CVE-2026-105859, GHSA-f7hx-52q9-hcrf
Record: https://patchnext.com/advisories/cve-2026-105859 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: payload 4.0.0-canary.34, 3.90.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm payload: affected < 3.90.0; >= 4.0.0-canary.0, < 4.0.0-canary.34; fixed in 4.0.0-canary.34, 3.90.0

## Suggested inspection (read-only)
- `npm ls payload --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on payload.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f7hx-52q9-hcrf (GitHub-reviewed advisory GHSA-f7hx-52q9-hcrf lists affected ranges: npm payload >=0 =4.0.0-canary.0 <4.0.0-canary.34)
- Verified: https://osv.dev/vulnerability/GHSA-f7hx-52q9-hcrf (OSV record GHSA-f7hx-52q9-hcrf lists affected ranges: npm payload >=0 =4.0.0-canary.0 <4.0.0-canary.34 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…