Skip to content

← Actionable
High, CVSS 8.1amended

Payload: Remote Code Execution through first-register

CVE-2026-105858GHSA-97rh-rhh2-7vjv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (payload 4.0.0-canary.34, 3.90.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm payload

    Affected
    < 3.90.0>= 4.0.0-canary.0, < 4.0.0-canary.34
    Fixed in
    4.0.0-canary.34, 3.90.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-105858: 0.47% estimated exploitation activity in the next 30 days; percentile 41.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A crafted request to the public first-register operation can be used to perform a RCE exploit. You are affected if: - You use local auth strategy and your application remains without an initial user created Patches In the patched version data submission to create first user is properly sanitized. Users should upgrade Payload packages to = 3.90.0 or = 4.0.0-canary.34.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-97rh-rhh2-7vjv

  2. Revision 2 · amended ·

    Amended from osv record GHSA-97rh-rhh2-7vjv

  3. Revision 1 · created ·

    Published from ghsa record GHSA-97rh-rhh2-7vjv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-105858

Advisory: Payload: Remote Code Execution through first-register
IDs: CVE-2026-105858, GHSA-97rh-rhh2-7vjv
Record: https://patchnext.com/advisories/cve-2026-105858 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: payload 4.0.0-canary.34, 3.90.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm payload: affected < 3.90.0; >= 4.0.0-canary.0, < 4.0.0-canary.34; fixed in 4.0.0-canary.34, 3.90.0

## Suggested inspection (read-only)
- `npm ls payload --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on payload.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-97rh-rhh2-7vjv (GitHub-reviewed advisory GHSA-97rh-rhh2-7vjv lists affected ranges: npm payload >=0 =4.0.0-canary.0 <4.0.0-canary.34)
- Verified: https://osv.dev/vulnerability/GHSA-97rh-rhh2-7vjv (OSV record GHSA-97rh-rhh2-7vjv lists affected ranges: npm payload >=0 =4.0.0-canary.0 <4.0.0-canary.34 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…