Skip to content

← Actionable
Medium, CVSS 6.9amended

Payload relationship-query authorization bypass

CVE-2026-105852GHSA-7c34-32v3-j575

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (payload 4.0.0-canary.34, 3.90.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm payload

    Affected
    < 3.90.0>= 4.0.0-canary.0, < 4.0.0-canary.34
    Fixed in
    4.0.0-canary.34, 3.90.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-105852: 0.27% estimated exploitation activity in the next 30 days; percentile 19.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A readable collection could expose information about protected documents in a related collection. You are affected if: - You expose a readable collection with a relationship to a collection protected by access.read where constraints. Patches Users should upgrade Payload packages to = 3.90.0 or = 4.0.0-canary.34. Workarounds There is no complete workaround. Upgrade Payload packages = 3.90.0 or = 4.0.0-canary.34.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-7c34-32v3-j575

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-7c34-32v3-j575

  4. Revision 1 · created ·

    Published from ghsa record GHSA-7c34-32v3-j575

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-105852

Advisory: Payload relationship-query authorization bypass
IDs: CVE-2026-105852, GHSA-7c34-32v3-j575
Record: https://patchnext.com/advisories/cve-2026-105852 (revision 4, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: payload 4.0.0-canary.34, 3.90.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm payload: affected < 3.90.0; >= 4.0.0-canary.0, < 4.0.0-canary.34; fixed in 4.0.0-canary.34, 3.90.0

## Suggested inspection (read-only)
- `npm ls payload --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on payload.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7c34-32v3-j575 (GitHub-reviewed advisory GHSA-7c34-32v3-j575 lists affected ranges: npm payload >=0 =4.0.0-canary.0 <4.0.0-canary.34)
- Verified: https://osv.dev/vulnerability/GHSA-7c34-32v3-j575 (OSV record GHSA-7c34-32v3-j575 lists affected ranges: npm payload >=0 =4.0.0-canary.0 <4.0.0-canary.34 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…