Payload: SQL Injection in SQLite and Postgres
CVE-2026-105845GHSA-v49j-62m6-pgrr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (payload 4.0.0-canary.27, 3.88.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm payload
- Affected
- >= 3.0.0, < 3.88.0>= 4.0.0-canary.0, < 4.0.0-canary.27
- Fixed in
- 3.88.0, 4.0.0-canary.27
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v49j-62m6-pgrr lists affected ranges: npm payload >=3.0.0 =4.0.0-canary.0 <4.0.0-canary.27
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v49j-62m6-pgrr lists affected ranges: npm payload >=3.0.0 =4.0.0-canary.0 <4.0.0-canary.27 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-105845: 0.38% estimated exploitation activity in the next 30 days; percentile 32.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A user can submit a request that exploits a SQL Injection vulnerability in Payload. You are affected if: - You use an affected Payload version. - Untrusted users can query readable collections using dynamic filters or joins. You are not affected if you use MongoDB (@payloadcms/mongodb). Patches Users should upgrade Payload packages to = 3.88.0 or = 4.0.0-canary.27. Workarounds Upgrading to a patched version is recommended. Until you can upgrade, restrict untrusted users from supplying dynamic query filters or join parameters and limit read access to affected collections.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v49j-62m6-pgrr
- Revision 2 · amended ·
Amended from osv record GHSA-v49j-62m6-pgrr
- Revision 1 · created ·
Published from ghsa record GHSA-v49j-62m6-pgrr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-105845 Advisory: Payload: SQL Injection in SQLite and Postgres IDs: CVE-2026-105845, GHSA-v49j-62m6-pgrr Record: https://patchnext.com/advisories/cve-2026-105845 (revision 3, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: payload 4.0.0-canary.27, 3.88.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm payload: affected >= 3.0.0, < 3.88.0; >= 4.0.0-canary.0, < 4.0.0-canary.27; fixed in 3.88.0, 4.0.0-canary.27 ## Suggested inspection (read-only) - `npm ls payload --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on payload. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v49j-62m6-pgrr (GitHub-reviewed advisory GHSA-v49j-62m6-pgrr lists affected ranges: npm payload >=3.0.0 =4.0.0-canary.0 <4.0.0-canary.27) - Verified: https://osv.dev/vulnerability/GHSA-v49j-62m6-pgrr (OSV record GHSA-v49j-62m6-pgrr lists affected ranges: npm payload >=3.0.0 =4.0.0-canary.0 <4.0.0-canary.27 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…