i18next-http-backend incomplete URL validation permits SSRF
CVE-2026-105800GHSA-xvq9-wjp8-hwqf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (i18next-http-backend 4.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 4.0.2
- Fixed in
- 4.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xvq9-wjp8-hwqf lists affected ranges: npm i18next-http-backend >=0 <4.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xvq9-wjp8-hwqf lists affected ranges: npm i18next-http-backend >=0 <4.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-105800: 0.29% estimated exploitation activity in the next 30 days; percentile 21.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is an SSRF vulnerability when using i18next-http-backend. A colon in an attacker-controlled language value can make a custom path template request an unintended origin. This is reachable under the following conditions: Attacker controls i18next language or namespace input that is interpolated into loadPath. Proof of Concept Run: The expected result is: Why the Previous Patch Was Incomplete This vulnerability is caused by an incomplete patch for CVE-2026-41691. The previous patch addressed the following behavior: Original hardening blocks path traversal and selected URL-control characters in lng/ns. The following bypass remains in the current release: lng=http:127.0.0.1:<port with loadPath={{lng}}/{{ns}}.json; colon is not blocked and produces an outbound request. Impact The attacker-controlled language or namespace value can redirect the backend request to an unintended origin, resulting in URL injection and possible SSRF. Recommended Fix Parse the final URL and require it to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xvq9-wjp8-hwqf
- Revision 2 · amended ·
Amended from osv record GHSA-xvq9-wjp8-hwqf
- Revision 1 · created ·
Published from ghsa record GHSA-xvq9-wjp8-hwqf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-105800 Advisory: i18next-http-backend incomplete URL validation permits SSRF IDs: CVE-2026-105800, GHSA-xvq9-wjp8-hwqf Record: https://patchnext.com/advisories/cve-2026-105800 (revision 3, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: i18next-http-backend 4.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm i18next-http-backend: affected < 4.0.2; fixed in 4.0.2 ## Suggested inspection (read-only) - `npm ls i18next-http-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on i18next-http-backend. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xvq9-wjp8-hwqf (GitHub-reviewed advisory GHSA-xvq9-wjp8-hwqf lists affected ranges: npm i18next-http-backend >=0 <4.0.2) - Verified: https://osv.dev/vulnerability/GHSA-xvq9-wjp8-hwqf (OSV record GHSA-xvq9-wjp8-hwqf lists affected ranges: npm i18next-http-backend >=0 <4.0.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…