Skip to content

← Actionable
Low, CVSS 2.3amended

LangChain: RediSearch Filter Injection via Unescaped Tag/Text Values

CVE-2026-105799GHSA-5x6v-p487-7qh2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@langchain/redis 1.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-105799: 0.28% estimated exploitation activity in the next 30 days; percentile 20.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary @langchain/redis did not properly escape values used to construct structured RediSearch TAG and TEXT filters. An application that passes attacker-controlled values into these filters could allow the attacker to alter the resulting search query. Affected versions @langchain/redis versions through 1.1.0 are affected. Impact An attacker who can control values passed to the affected structured TAG or TEXT filters can inject RediSearch syntax and alter or broaden the resulting search query. In applications that use an attacker-influenceable filter as a tenant or document-access boundary, this may expose indexed documents outside the attacker's intended scope. Remediation Upgrade to @langchain/redis 1.1.1 or later. The fix escapes RediSearch special characters, validates field names and structured filter types, and applies these protections across fluent filter builders and custom-schema query construction. Credits Thanks to @thesanjok and @shovanchakraborty for reporting this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-5x6v-p487-7qh2

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-5x6v-p487-7qh2

  4. Revision 1 · created ·

    Published from ghsa record GHSA-5x6v-p487-7qh2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-105799

Advisory: LangChain: RediSearch Filter Injection via Unescaped Tag/Text Values
IDs: CVE-2026-105799, GHSA-5x6v-p487-7qh2
Record: https://patchnext.com/advisories/cve-2026-105799 (revision 4, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @langchain/redis 1.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @langchain/redis: affected <= 1.1.0; fixed in 1.1.1

## Suggested inspection (read-only)
- `npm ls @langchain/redis --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @langchain/redis.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5x6v-p487-7qh2 (GitHub-reviewed advisory GHSA-5x6v-p487-7qh2 lists affected ranges: npm @langchain/redis >=0 <=1.1.0)
- Verified: https://osv.dev/vulnerability/GHSA-5x6v-p487-7qh2 (OSV record GHSA-5x6v-p487-7qh2 lists affected ranges: npm @langchain/redis >=0 <1.1.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…