Kiota: Unsafe oauth_card_path references in Kiota-generated API plugin manifests
CVE-2026-105795GHSA-6gw6-rv2g-25mg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (microsoft.openapi.kiota 1.35.0; microsoft.openapi.kiota.builder 1.35.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet microsoft.openapi.kiota
- Affected
- >= 1.25.1, < 1.35.0
- Fixed in
- 1.35.0
NuGet microsoft.openapi.kiota.builder
- Affected
- >= 1.25.1, < 1.35.0
- Fixed in
- 1.35.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6gw6-rv2g-25mg lists affected ranges: NuGet microsoft.openapi.kiota >=1.25.1 =1.25.1 <1.35.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6gw6-rv2g-25mg lists affected ranges: NuGet microsoft.openapi.kiota >=1.25.1 =1.25.1 <1.35.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-105795: 1.21% estimated exploitation activity in the next 30 days; percentile 68.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When generating an API plugin manifest from an attacker-controlled or compromised OpenAPI description, Kiota copies x-ai-capabilities.responsesemantics.oauthcardpath into the manifest without validating that it is a safe package-relative file reference. An attacker can supply parent-directory traversal, rooted paths, or absolute URIs instead of a card file within the plugin package. The unsafe reference is propagated into the generated manifest. Its security effect depends on the downstream host's handling of the reference when the plugin is packaged and deployed. This is not local code execution or a file read performed by Kiota merely during generation. A consuming host that resolves the untrusted reference can cross the intended package boundary or use an unintended authentication card. Affected versions The affected NuGet packages are Microsoft.OpenApi.Kiota and Microsoft.OpenApi.Kiota.Builder, starting with version 1.25.1, which introduced this manifest field. The field…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6gw6-rv2g-25mg
- Revision 1 · created ·
Published from osv record GHSA-6gw6-rv2g-25mg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-105795 Advisory: Kiota: Unsafe oauth_card_path references in Kiota-generated API plugin manifests IDs: CVE-2026-105795, GHSA-6gw6-rv2g-25mg Record: https://patchnext.com/advisories/cve-2026-105795 (revision 2, source checked 26 Oct 2026, 17:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: microsoft.openapi.kiota 1.35.0; microsoft.openapi.kiota.builder 1.35.0. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet microsoft.openapi.kiota: affected >= 1.25.1, < 1.35.0; fixed in 1.35.0 - NuGet microsoft.openapi.kiota.builder: affected >= 1.25.1, < 1.35.0; fixed in 1.35.0 ## Suggested inspection (read-only) - NuGet microsoft.openapi.kiota: check the installed version with your package manager. - NuGet microsoft.openapi.kiota.builder: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on microsoft.openapi.kiota, microsoft.openapi.kiota.builder. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6gw6-rv2g-25mg (OSV record GHSA-6gw6-rv2g-25mg lists affected ranges: NuGet microsoft.openapi.kiota >=1.25.1 =1.25.1 <1.35.0 (fixed)) - Verified: https://github.com/advisories/GHSA-6gw6-rv2g-25mg (GitHub-reviewed advisory GHSA-6gw6-rv2g-25mg lists affected ranges: NuGet microsoft.openapi.kiota >=1.25.1 =1.25.1 <1.35.0) Commands are suggestions: review each one before running it.
Loading voting…