Skip to content

← Actionable
Medium, CVSS 5.3amended

vLLM: GLMGA video sampling permits request-driven CPU and memory exhaustion

CVE-2026-105760GHSA-58v5-2m8f-94pr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.30.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    >= 0.23.0rc2, < 0.30.0
    Fixed in
    0.30.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-105760: 0.30% estimated exploitation activity in the next 30 days; percentile 22.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The OpenAI-compatible chat endpoint accepts request-level video loader options through mediaiokwargs. A caller can select the GLMGA sampler and provide large fps and maxframes values. GLMGA first constructs an attacker-sized Python index list and then deduplicates it, even when the supplied video contains only a few frames. This work occurs in the shared media-loading executor before frame reads, allowing a tiny valid video and compact JSON options to consume disproportionate CPU time and memory and delay unrelated media requests. The demonstrated impact is partial denial of service. No memory corruption, data disclosure, or code execution is claimed. Affected configuration The server must expose chat completions for a video-capable model and accept request-level mediaiokwargs. The model does not need to use GLMGA by default because the request value overrides the model's loader mapping. The proof of concept uses an inline two-frame video and explicitly selects the OpenCV…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-58v5-2m8f-94pr

  2. Revision 2 · amended ·

    Amended from osv record GHSA-58v5-2m8f-94pr

  3. Revision 1 · created ·

    Published from ghsa record GHSA-58v5-2m8f-94pr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-105760

Advisory: vLLM: GLMGA video sampling permits request-driven CPU and memory exhaustion
IDs: CVE-2026-105760, GHSA-58v5-2m8f-94pr
Record: https://patchnext.com/advisories/cve-2026-105760 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.30.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected >= 0.23.0rc2, < 0.30.0; fixed in 0.30.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-58v5-2m8f-94pr (GitHub-reviewed advisory GHSA-58v5-2m8f-94pr lists affected ranges: PyPI vllm >=0.23.0rc2 <0.30.0)
- Verified: https://osv.dev/vulnerability/GHSA-58v5-2m8f-94pr (OSV record GHSA-58v5-2m8f-94pr lists affected ranges: PyPI vllm >=0.23.0rc2 <0.30.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…